Plausibilitätsprüfung

31/10/2011 - 10:21 von Detlef Paschke | Report spam
Hallo,

in einer Tabelle die als Datenbank dient werden in Spalte $E Seriennummern
eingetragen die unter anderem auch den Standort enthalten. In den Spalten $A
bis $D stehen die dazugehörigen Standortdaten. Als Beispiel:
$A: Z036 (laufende Nummer); $B: 60 (Haus); $C: 01 (Ebene); $D: 05 (Raum);
$E: 60.01.05.RLT3.BSK.Z036 (Seriennummer)

Nun möchte ich eine Plausibilitàtsprüfung die mir per bedingter Formatierung
Eingabefehler zeigt. Ein Versuch mit der Funktion TEIL hat mich noch nicht
weitergebracht, da sich TEIL auf eine bestimmte Stellenanzahl bezieht. Die
Stellenanzahl ist aber Variabel und auch der ZUSATZ, im obigen Beispiel
RLT3.BSK, der nicht gelistet wird ist mal mehr oder weniger groß.
Einzig immer gleich ist die Trennung mit einem Punkt wobei z.B. bei
60.01.09.RLT1.1.BSK.A076 auch mehrere Punkte innerhalb des ZUSATZ sind.
Es müsste also in etwa so Arbeiten: HAUS bis zum ersten Punkt; EBENE
zwischen ersten und zweiten Punkt; RAUM zwischen zweiten und dritten Punkt;
LAUFENDE NUMMER nach dem letzten Punkt.

Wie kann eine solche Prüfung bzw. Vergleich in eine Formel gepackt werden?

Viele Grüße
Detlef Paschke
 

Lesen sie die antworten

#1 Peter Schuerer
31/10/2011 - 11:04 | Warnen spam
Am 31.10.2011 10:21, schrieb Detlef Paschke:

Hallo Detlef,
Es müsste also in etwa so Arbeiten: HAUS bis zum ersten Punkt; EBENE
zwischen ersten und zweiten Punkt; RAUM zwischen zweiten und dritten Punkt;
LAUFENDE NUMMER nach dem letzten Punkt.




Die erste Formel prüft nur auf "Haus", "Ebene" und "Raum":

=WENN((B2&"."&C2&"."&D2&".")<>LINKS(E2;9);"Falsch";"Richtig")

Die zweite Formel prüft extra noch auf die laufende Nummer:

=WENN(ODER((B3&"."&C3&"."&D3&".")<>LINKS(E3;9);A3<>RECHTS(E3;4));"Falsch";"Richtig")

Die Werte in Spalte A bis E müssen als Text formatiert sein.

MfG
Peter

Ähnliche fragen