Postback falsch bei Port Forwarding

07/05/2008 - 19:12 von Carsten | Report spam
Habe das Problem, dass die Postback Scripts falsch sind, wenn ich mit einem
Port Forwarding arbeite. Mein Web Server làuft auf Port 90 und ist nur über
ein Port-Forwarding zu erreichen. Die Sub Domain làuft auf Port 80 und macht
ein Forwarding auf Port 90 des Web Servers. Schaue ich nun in das Skript
meines Buttons finde ich diese Adresse: http://wbe.protel-net.com:90/

Das ist aber falsch, da die Applikation zwar unter dieser subdomain zu
erreichen ist, aber auf port 80. Wie bekomme ich die Postback scripts dazu
den Port 80 zu verwenden? Muss ich jetzt überall eine Postback URL angeben?
Und warum funktioniert der Postback bei den DropDown Listen und nicht b eim
Button? Das erscheint mir nicht logisch.

Carsten
 

Lesen sie die antworten

#1 Carsten
07/05/2008 - 19:20 | Warnen spam
Ihr könnt den Beitrag ignorieren. Ich hab bei dem Button die Postback URL
manuell gesetzt und request.url liefert mir den falschen Port zurück. Ich
denke wenn ich die postback url nicht explizit setze, wird es funktionieren.
Warum mir request.url den falschen port liefert, weiß ich nicht, aber das
soll jetzt nich mein Problem sein.

"Carsten" wrote:

Habe das Problem, dass die Postback Scripts falsch sind, wenn ich mit einem
Port Forwarding arbeite. Mein Web Server làuft auf Port 90 und ist nur über
ein Port-Forwarding zu erreichen. Die Sub Domain làuft auf Port 80 und macht
ein Forwarding auf Port 90 des Web Servers. Schaue ich nun in das Skript
meines Buttons finde ich diese Adresse: http://wbe.protel-net.com:90/

Das ist aber falsch, da die Applikation zwar unter dieser subdomain zu
erreichen ist, aber auf port 80. Wie bekomme ich die Postback scripts dazu
den Port 80 zu verwenden? Muss ich jetzt überall eine Postback URL angeben?
Und warum funktioniert der Postback bei den DropDown Listen und nicht b eim
Button? Das erscheint mir nicht logisch.

Carsten

Ähnliche fragen