PowerShell 2.0 in Verbindung mit Exchange 2010

18/05/2010 - 17:06 von Rainer Gras | Report spam
Hallo zusammen,

in einer Testumgebung habe ich folgendes Problem festgelstellt.

Wir sprechen hier über Windows 2008 R2 x64 ENG
Wenn ich auf dem DC auf "Start" -> "Administrative Tools" und dann mit der rechten Maustaste auf "Windows PowerShell Modules" klicke
und dann "Run as administrator" auswàhle, werden die einzelnen Module geladen.
Mit Get-Module bekomme ich diese aufgelistet.

Soweit so gut.

Installiere ich auf einem Member Server die CAS Rolle (welche Rolle ist egal) und ich wiederhole den oben geschilderten Vorgang auf
der Maschine auf der die CAS Rolle làuft, bekomme ich folgende Fehlermeldung:

Windows PowerShell
Copyright (C) 2009 Microsoft Corporation. All rights reserved.

Import-Module : There were errors in loading the format data file:
Microsoft.Exchange.Management.PowerShell.Setup, C:\Program Files\Microsoft\Exchange Server\V14\bin\Exchange.format.ps1x
ml : File skipped because it was already present from "Microsoft.Exchange.Management.PowerShell.E2010".
At line:24 char:34
+ Import-Module <<<< $_.Name -ErrorAction SilentlyContinue
+ CategoryInfo : InvalidOperation: (:) [Import-Module], RuntimeException
+ FullyQualifiedErrorId : FormatXmlUpateException,Microsoft.PowerShell.Commands.ImportModuleCommand

PS C:\Users\Administrator.LOCAL>


Die Rolle ist egal, ob HUB Transport oder Mailboxrolle, sobald Exchange 2010 installiert ist kommt die oben beschriebenen
Fehlermeldung.
Get-Module zeigt nichts mehr an.

Ob "Run as administrator" oder nicht spielt dabei keine Rolle. Installiert wurde als Domàne Admin.

Danke für eure Mühe.

Gruß
Rainer
 

Lesen sie die antworten

#1 Varnik
04/06/2010 - 20:52 | Warnen spam
Open this file in Notepad, go to the line:24 and retype char:34 or a whole
word (Daten), save the file and import the modules.
It seems that a letter "a" is written in other keyboard layout than english
(probably cyrillic)

Best regards
Nik

"Rainer Gras" wrote:

Hallo zusammen,

in einer Testumgebung habe ich folgendes Problem festgelstellt.

Wir sprechen hier über Windows 2008 R2 x64 ENG
Wenn ich auf dem DC auf "Start" -> "Administrative Tools" und dann mit der rechten Maustaste auf "Windows PowerShell Modules" klicke
und dann "Run as administrator" auswàhle, werden die einzelnen Module geladen.
Mit Get-Module bekomme ich diese aufgelistet.

Soweit so gut.

Installiere ich auf einem Member Server die CAS Rolle (welche Rolle ist egal) und ich wiederhole den oben geschilderten Vorgang auf
der Maschine auf der die CAS Rolle làuft, bekomme ich folgende Fehlermeldung:

Windows PowerShell
Copyright (C) 2009 Microsoft Corporation. All rights reserved.

Import-Module : There were errors in loading the format data file:
Microsoft.Exchange.Management.PowerShell.Setup, C:\Program Files\Microsoft\Exchange Server\V14\bin\Exchange.format.ps1x
ml : File skipped because it was already present from "Microsoft.Exchange.Management.PowerShell.E2010".
At line:24 char:34
+ Import-Module <<<< $_.Name -ErrorAction SilentlyContinue
+ CategoryInfo : InvalidOperation: (:) [Import-Module], RuntimeException
+ FullyQualifiedErrorId : FormatXmlUpateException,Microsoft.PowerShell.Commands.ImportModuleCommand

PS C:\Users\Administrator.LOCAL>


Die Rolle ist egal, ob HUB Transport oder Mailboxrolle, sobald Exchange 2010 installiert ist kommt die oben beschriebenen
Fehlermeldung.
Get-Module zeigt nichts mehr an.

Ob "Run as administrator" oder nicht spielt dabei keine Rolle. Installiert wurde als Domàne Admin.

Danke für eure Mühe.

Gruß
Rainer

.

Ähnliche fragen