preferences: pin wird ignoriert

21/01/2015 - 16:40 von Denny Bortfeldt | Report spam

Hallo zusammen,

ich habe ein kleines Problem bzgl. pinning von Release-Repositorys und hoffe, jemand kann mir helfen.

In der sources.list wurde zusàtzlich zum Standard Repo das testing-Repo hinzugefügt:
deb http://ftp.debian.org/debian testing main contrib non-free

via "preferences" wurde das pinning so gesetzt, dass _eigentlich_ nur aus dem Stable installiert werden soll:
Package: *
Pin: release a=stable
Pin-Priority: 700

Package: *
Pin: release a=testing
Pin-Priority: 600


Sofern ich jetzt aber ein "apt-get update && apt-get -s upgrade" mache, wird versucht jedes Paket, welches in testing vorhanden ist, zu aktualisieren mit der Version aus testing:
[...]
Inst debian-archive-keyring [2014.3~deb7u1] (2014.3 Debian:testing [all])
Conf debian-archive-keyring (2014.3 Debian:testing [all])
Inst gnupg [1.4.12-7+deb7u6] (1.4.18-6 Debian:testing [amd64])
Conf gnupg (1.4.18-6 Debian:testing [amd64])
Inst libpam-runtime [1.1.3-7.1] (1.1.8-3.1 Debian:testing [all])
Conf libpam-runtime (1.1.8-3.1 Debian:testing [all])
Inst multiarch-support [2.13-38+deb7u6] (2.19-13 Debian:testing [amd64])
Conf multiarch-support (2.19-13 Debian:testing [amd64])
Inst tzdata [2014j-0wheezy1] (2014j-1 Debian:testing [all])
Conf tzdata (2014j-1 Debian:testing [all])
[...]

/etc# apt-cache policy tzdata
tzdata:
Installed: 2014j-0wheezy1
Candidate: 2014j-1
Version table:
2014j-1 0
600 http://ftp.debian.org/debian/ testing/main amd64 Packages
*** 2014j-0wheezy1 0
500 http://ftp.debian.org/debian/ wheezy/main amd64 Packages
100 /var/lib/dpkg/status


Kann mir bitte jemand erklàren, warum nun sàmtliche Pakete aus testing installiert werden will? Bei anderen Servern besteht das Problem nicht.

Gruß
Denny


<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office...omml" xmlns="http://www.w3.org/TR/REC-html40">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<meta name="Generator" content="Microsoft Word 14 (filtered medium)">
<style><!--
/* Font Definitions */
@font-face
{font-family:"Cambria Math";
panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
{font-family:Calibri;
panose-1:2 15 5 2 2 2 4 3 2 4;}
@font-face
{font-family:"Soho Gothic Pro";
panose-1:2 11 5 3 3 5 4 2 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
{margin:0cm;
margin-bottom:.0001pt;
font-size:11.0pt;
font-family:"Calibri","sans-serif";
mso-fareast-language:EN-US;}
a:link, span.MsoHyperlink
{mso-style-priority:99;
color:blue;
text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
{mso-style-priority:99;
color:purple;
text-decoration:underline;}
span.E-MailFormatvorlage17
{mso-style-type:personal-compose;
font-family:"Calibri","sans-serif";
color:windowtext;}
.MsoChpDefault
{mso-style-type:export-only;
font-family:"Calibri","sans-serif";
mso-fareast-language:EN-US;}
@page WordSection1
{size:612.0pt 792.0pt;
margin:70.85pt 70.85pt 2.0cm 70.85pt;}
div.WordSection1
{page:WordSection1;}
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]-->
</head>
<body lang="DE" link="blue" vlink="purple">
<div class="WordSection1">
<p class="MsoNormal">Hallo zusammen,<o:p></o:p></p>
<p class="MsoNormal"><o:p>&nbsp;</o:p></p>
<p class="MsoNormal">ich habe ein kleines Problem bzgl. pinning von Release-Repositorys und hoffe, jemand kann mir helfen.<o:p></o:p></p>
<p class="MsoNormal"><o:p>&nbsp;</o:p></p>
<p class="MsoNormal">In der sources.list wurde zusàtzlich zum Standard Repo das testing-Repo hinzugefügt:<o:p></o:p></p>
<p class="MsoNormal"><span lang="EN-US">deb http://ftp.debian.org/debian testing main contrib non-free<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US"><o:p>&nbsp;</o:p></span></p>
<p class="MsoNormal">via &#8220;preferences&#8221; wurde das pinning so gesetzt, dass _<i>eigentlich</i>_ nur aus dem Stable installiert werden soll:<o:p></o:p></p>
<p class="MsoNormal"><span lang="EN-US">Package: *<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">Pin: release a=stable<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">Pin-Priority: 700<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US"><o:p>&nbsp;</o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">Package: *<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">Pin: release a=testing<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">Pin-Priority: 600<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US"><o:p>&nbsp;</o:p></span></p>
<p class="MsoNormal"><span lang="EN-US"><o:p>&nbsp;</o:p></span></p>
<p class="MsoNormal">Sofern ich jetzt aber ein &#8220;apt-get update &amp;&amp; apt-get &#8211;s upgrade&#8221; mache, wird versucht jedes Paket, welches in testing vorhanden ist, zu aktualisieren mit der Version aus testing:<o:p></o:p></p>
<p class="MsoNormal"><span lang="EN-US">[&#8230;]<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">Inst debian-archive-keyring [2014.3~deb7u1] (2014.3 Debian:testing [all])<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">Conf debian-archive-keyring (2014.3 Debian:testing [all])<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">Inst gnupg [1.4.12-7&#43;deb7u6] (1.4.18-6 Debian:testing [amd64])<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">Conf gnupg (1.4.18-6 Debian:testing [amd64])<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">Inst libpam-runtime [1.1.3-7.1] (1.1.8-3.1 Debian:testing [all])<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">Conf libpam-runtime (1.1.8-3.1 Debian:testing [all])<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">Inst multiarch-support [2.13-38&#43;deb7u6] (2.19-13 Debian:testing [amd64])<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">Conf multiarch-support (2.19-13 Debian:testing [amd64])<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">Inst tzdata [2014j-0wheezy1] (2014j-1 Debian:testing [all])<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">Conf tzdata (2014j-1 Debian:testing [all])<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">[&#8230;]<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US"><o:p>&nbsp;</o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">/etc# apt-cache policy tzdata<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">tzdata:<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">&nbsp; Installed: 2014j-0wheezy1<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">&nbsp; Candidate: 2014j-1<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">&nbsp; Version table:<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">&nbsp;&nbsp;&nbsp;&nbsp; 2014j-1 0<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 600 http://ftp.debian.org/debian/ testing/main amd64 Packages<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">*** 2014j-0wheezy1 0<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 500 http://ftp.debian.org/debian/ wheezy/main amd64 Packages<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; 100 /var/lib/dpkg/status<o:p></o:p></span></p>
<p class="MsoNormal"><span lang="EN-US"><o:p>&nbsp;</o:p></span></p>
<p class="MsoNormal"><span lang="EN-US"><o:p>&nbsp;</o:p></span></p>
<p class="MsoNormal">Kann mir bitte jemand erklàren, warum nun sàmtliche Pakete aus testing installiert werden will? Bei anderen Servern besteht das Problem nicht.<o:p></o:p></p>
<p class="MsoNormal"><span style="font-size:10.0pt;font-family:&quot;Soho Gothic Pro&quot;;color:#323232;mso-fareast-language:DE"><o:p>&nbsp;</o:p></span></p>
<p class="MsoNormal"><span style="font-size:10.0pt;font-family:&quot;Soho Gothic Pro&quot;;color:#323232;mso-fareast-language:DE">Gruß<o:p></o:p></span></p>
<p class="MsoNormal"><span style="font-size:10.0pt;font-family:&quot;Soho Gothic Pro&quot;;color:#323232;mso-fareast-language:DE">Denny</span><span lang="EN-US"><o:p></o:p></span></p>
</div>
</body>
</html>



Zum AUSTRAGEN schicken Sie eine Mail an debian-user-german-REQUEST@lists.debian.org
mit dem Subject "unsubscribe". Probleme? Mail an listmaster@lists.debian.org (engl)
Archive: https://lists.debian.org/6FF2272C0D...C62C423A35@s015011.office.babiel.com
 

Lesen sie die antworten

#1 Sven Hartge
21/01/2015 - 18:10 | Warnen spam
Denny Bortfeldt wrote:

via "preferences" wurde das pinning so gesetzt, dass _eigentlich_ nur aus dem Stable installiert werden soll:
Package: *
Pin: release a=stable
Pin-Priority: 700

Package: *
Pin: release a=testing
Pin-Priority: 600


Kann mir bitte jemand erklàren, warum nun sàmtliche Pakete aus testing
installiert werden will? Bei anderen Servern besteht das Problem
nicht.



Weil Testing eine Priority > 500 hat. Siehe apt_preferences(5).
Setze Testing auf irgendwas zwischen 100 und 500, dann klappt das auch.



Sigmentation fault. Core dumped.


Zum AUSTRAGEN schicken Sie eine Mail an
mit dem Subject "unsubscribe". Probleme? Mail an (engl)
Archive: https://lists.debian.org/

Ähnliche fragen