Preisfindung mit Gültig-ab-Datum

16/06/2009 - 08:34 von Lothar Krause | Report spam
Hallo,

In der Tabelle1 stehen folgende Daten:

Kunde Stück Monat
1 10 01
2 20 02
1 30 02
1 40 03


In der Tabelle2 gibt es folgende Daten:

Kunde Preis pro Stück Gültig ab
1 50 01
2 60 02
1 60 03


Frage: Wie kann mit einer WENN- bzw. SVERWEIS-Formel sichergestellen werden,
dass im vorgenannten Beispiel beim Kunden-Nr. 1 für die Monate 01 und 02 der
Preis/Stck. von 50 gezogen wird und ab Monat 03 mit 60 pro Stck. gerechnet
wird? Oder gibt es eine andere Möglichkeit als die ‚Wenn-’ bzw.
‚Sverweis-Formel’.

MfG
Lothar Krause
 

Lesen sie die antworten

#1 Alexander Wolff
16/06/2009 - 10:34 | Warnen spam
Tabelle 1 benötige ich nicht ...

In der Tabelle2 gibt es folgende Daten:

Kunde Preis pro Stück Gültig ab
1 50 01
2 60 02
1 60 03

Frage: Wie kann mit einer WENN- bzw. SVERWEIS-Formel sichergestellen
werden, dass im vorgenannten Beispiel beim Kunden-Nr. 1 für die
Monate 01 und 02 der Preis/Stck. von 50 gezogen wird und ab Monat 03
mit 60 pro Stck. gerechnet wird? Oder gibt es eine andere Möglichkeit
als die ,Wenn-' bzw. ,Sverweis-Formel'.



{=VERGLEICH(C1*1000&A1;C4:C6*1000&A4:A6;)}

{} bedeutet: nicht eintippen, sondern bei Abschließen der Formel mit
Strg-Umsch-Eingabe erzeugen -> Matrixformel

wobei:

C1: Gesuchter Monat (3)
A1: Gesuchter Kunde (1)

C4:C6: Liste mit Monaten
A4:A6: Liste mit Kunden

VERGLEICH gibt die Position innerhalb einer Liste wieder (3), auf die Du
mittels INDEX zugreifen kannst:

{=INDEX(B4:B6;VERGLEICH(C1*1000&A1;C4:C6*1000&A4:A6;))}

wobei

B4:B6: Preis pro Stück
Moin+Gruss Alexander - MVP for MS Excel - www.xxcl.de - mso2000sp3 --7-2

Ähnliche fragen