Problem bei der Installation von Grub

20/02/2011 - 15:40 von Peter Schütt | Report spam
Hallo,
ich habe den Rechner meiner Mutter neu aufgesetzt (vorher war nur
Windows 7) drauf und habe
zusàtzlich Debian-Squeeze drauf gemacht (auf extra Partitionen), was
auch gut funktioniert und was
sie auch in erster Linie benutzt.

Bei jedem Update bekomme ich folgende Meldungen, die mich nervös
machen, obwohl immer alles
funktioniert.




















update-initramfs: deferring update (trigger activated)
grub-common (1.98+20100804-14) wird eingerichtet ...
Neue Version der Konfigurationsdatei /etc/grub.d/10_linux wird
installiert ...
Neue Version der Konfigurationsdatei /etc/grub.d/20_linux_xen wird
installiert ...
grub-pc (1.98+20100804-14) wird eingerichtet ...
Neue Version der Konfigurationsdatei /etc/grub.d/05_debian_theme wird
installiert ...
Neue Version der Konfigurationsdatei /etc/kernel/postinst.d/zz-update-
grub wird installiert ...
Neue Version der Konfigurationsdatei /etc/kernel/postrm.d/zz-update-
grub wird installiert ...
Installation finished. No error reported.
/usr/sbin/grub-setup: warn: Es wird versucht, GRUB in eine Partition
anstelle in den MBR zu installieren. Das ist eine SCHLECHTE Idee..
/usr/sbin/grub-setup: warn: Embedding is not possible. GRUB can only
be installed in this setup by using blocklists. However, blocklists
are UNRELIABLE and their use is discouraged..
Installation finished. No error reported.
Generating grub.cfg ...
Removing old background image: moreblue-orbit-grub.png
Found background image: /usr/share/images/desktop-base/desktop-
grub.png
Found linux image: /boot/vmlinuz-2.6.32-5-amd64
Found initrd image: /boot/initrd.img-2.6.32-5-amd64
Found linux image: /boot/vmlinuz-2.6.32-3-amd64
Found initrd image: /boot/initrd.img-2.6.32-3-amd64
Found linux image: /boot/vmlinuz-2.6.26-2-amd64
Found initrd image: /boot/initrd.img-2.6.26-2-amd64
Found Windows Recovery Environment (loader) on /dev/sda1
Found Windows 7 (loader) on /dev/sda2
done
<<<<<<
Anscheinend habe ich bei der Installation GRUB nicht in den MBR
installiert und anscheinend ist das nicht
gut.
Reicht ein grub-install /dev/sda oder zerstöre ich damit etwas?

Danke für alle Hinweise und Tips.

Ciao
Peter Schütt
 

Lesen sie die antworten

#1 G
20/02/2011 - 16:20 | Warnen spam
Hi,

Anscheinend habe ich bei der Installation GRUB nicht in den MBR
installiert und anscheinend ist das nicht gut.



Genau so ist es. Statt auf sda versehentlich auf sda1 gedrückt. Passiert.

Reicht ein grub-install /dev/sda oder zerstöre ich damit etwas?



Meiner Meinung nach reicht das. Du zerstörst den im MBR vorhandenen
Startcode von MS. Das ist aber nicht schlimm, da er Windows erkannt hat
und schon bei dir über chainloader eingebunden hat. Prüfe, ob du Windows
bereits jetzt starten kannst, dann sichere einfach z.B. mit "dd if=/dev/
sda of=mbr.dd bs=1 countD0" den Startsektor von MS (sicher ist sicher)
und installiere grub drüber. Danach sollte auch alles gehen und du wirst
die Sicherung nicht mehr brauchen.

Grüße!

Ähnliche fragen