Problem bei Installation von Windows 2000 auf SATA-Platte

17/01/2010 - 19:24 von Michael Landenberger | Report spam
Hallo,

hier soll an einem àlteren PC Windows 2000 auf einer SATA-Platte installiert
werden. Das Mainboard (Intel SR440BX) hat keine SATA-Ports, daher steckt ein
PCI-SATA1-Controller mit SIL3512 drin. Der Controller hat bisher prima
funktioniert, allerdings waren die daran angeschlossenen Laufwerke nicht die
Bootlaufwerke (die Bootplatte war bisher eine IDE-Platte). Nun soll eine der
SATA-Platten (Samsung SP2504) die IDE-Platte ersetzen und jetzt das
Bootlaufwerk werden.

Ich habe zunàchst eine Treiberdiskette für den SATA-Controller erstellt, um
diese per F6 in das Windows-Setup einbinden zu können. Die Bootreihenfolge
im Mainboard-BIOS ist auf SCSI-CDROM-Floppy eingestellt. Das Mainboard-BIOS
erkennt den Controller und der wiederum die Platte. Windows-Setup startet
ganz normal von CDROM, wobei per Druck auf F6 auch der SATA-Treiber von
Diskette problemlos eingebunden wird. Dann kommt der Punkt, wo das
Windows-Setup die Platte partitionieren und formatieren will. Auch hier wird
die Platte samt ihrer Kapazitàt korrekt angezeigt, allerdings zusammen mit
dem etwas verwirrenden Hinweis "Unbekannter Datentràger - Es ist kein Medium
im Laufwerk eingelegt". Es làsst sich aber eine Partition anlegen (in diesem
Fall auf dem gesamten verfügbaren Speicherplatz), nach dem Auswàhlen dieser
Partition für die Windows-Installation meldet das Windows-Setup jedoch, dass
die Partition nicht Windows-2000-kompatibel sei. Danach landet man wieder
auf dem Bildschirm zum Partitionieren der Platte. Löschen und Neuanlegen der
Partition ist zwar möglich, bringt aber nichts, da das Setup wieder mit der
gleichen Fehlermeldung abbricht.

Ich habe das Spielchen dann mit einem anderen Controller (einem
SATA-/IDE-Kombicontroller mit VIA VT6421-Chipsatz) wiederholt, mit exakt
demselben Ergebnis (natürlich habe ich für diesen Controller eine passende
Treiberdiskette verwendet). Auch dieser Controller wird vom Mainboard
erkannt und der Controller wiederum erkennt die Platte. Auch hier làsst sich
die Treiberdiskette per F6 problemlos einbinden und auf der Seite für die
Partitionierung wird die Platte samt Größe korrekt angezeigt, allerdings
wieder mit dem Hinweis "Unbekannter Datentràger...". Und auch hier meckert
das Windows-Setup, dass eine soeben erfolgreich (!) angelegte Partition
nicht Windows 2000-kompatibel sei, und schickt einen immer wieder zurück auf
die Partitionierungsseite.

Auf dem Mainboard und den beiden Controllern ist jeweils die aktuellste
verfügbare Firmware drauf, ebenso verwende ich die aktuellsten Treiber.
Grundsàtzlich unterstützt das Mainboard auch das Booten über PCI-Controller,
wenn "SCSI" als Bootmedium eingetragen ist, allerdings funktionierte das
bisher nur mit einem Promise IDE-Controller sowie über den IDE-Port des
VIA-Controllers. Mit den SATA-Controllern klappt aber noch nicht einmal die
Installation, daher kann ich nicht sagen, ob der Rechner über SATA booten
kann.

Google hat mir leider nichts Erhellendes zu diesem Problem geliefert. Gibt
es überhaupt eine Lösung oder kann ich mein Vorhaben knicken?

Gruß

Michael
 

Lesen sie die antworten

#1 Michael Landenberger
17/01/2010 - 19:49 | Warnen spam
"Michael Landenberger" schrieb:

Gibt es überhaupt eine Lösung oder kann ich mein Vorhaben knicken?



Es gibt eine: Ursache für das Problem war offenbar ein ZIP-Laufwerk am 2.
IDE-Port des Mainboards. Das hat das Windows-Setup wohl verwirrt. Nach
Deaktivierung des 2. IDE-Ports im BIOS wird das ZIP-Laufwerk nun ignoriert
und Setup làuft durch. Jetzt ist es jetzt gerade dabei, die Platte zu
formatieren. Soweit also erstmal alles gut :-)

Außerdem habe ich den SATA-Controller vom 2. auf den 1. PCI-Slot umgesetzt.
Ich denke aber nicht, dass das die Ursache war, sondern dass das
ZIP-Laufwerk dazwischengefunkt hat.

Gruß

Michael

Ähnliche fragen