Problem beim Installieren von Virtual Box unter wheezy

10/02/2014 - 16:40 von tlahcuilo | Report spam
Hallo in die Runde,

beim Installieren von Virtual Box-dkms erhalte ich folgende Fehlermeldung, die, egal welches andere Paket ich installiere oder aktualisiere, stàndig wiederholt. Es scheint sich um ein zurückgehaltenes Paket zu handeln.
Die Virtual Box wird auf dem GUI incl. Icon als installiert angezeigt (Debian wheezy 32 bits).
Was kann ich tun, damit sich das nicht stàndig wiederholt und das Paket endlich korrekt installiert wird?

Vielen Dank für Eure Hilfe.

Stephan


Fehler traten auf beim Bearbeiten von:
virtualbox-dkms
E: Sub-process /usr/bin/dpkg returned an error code (1)
Ein Paket konnte nicht installiert werden. Wiederherstellung wird versucht:
virtualbox-dkms (4.1.18-dfsg-2+deb7u1) wird eingerichtet ...
Removing old virtualbox-4.1.18 DKMS files...


Deleting module version: 4.1.18
completely from the DKMS tree.

Done.
Loading new virtualbox-4.1.18 DKMS files...
First Installation: checking all kernels...
Building only for 3.9.6
Building initial module for 3.9.6
Error! Bad return status for module build on kernel: 3.9.6 (i686)
Consult /var/lib/dkms/virtualbox/4.1.18/build/make.log for more information.
dpkg: Fehler beim Bearbeiten von virtualbox-dkms (--configure):
Unterprozess installiertes post-installation-Skript gab den Fehlerwert 10 zurück
Fehler traten auf beim Bearbeiten von:
virtualbox-dkms

make.log sagt (schon ein paar Tage her):

DKMS make.log for virtualbox-4.1.18 for kernel 3.9.6 (i686)
Di 21. Jan 22:58:54 UTC 2014
make: Entering directory `/usr/src/linux-headers-3.9.6'
LD /var/lib/dkms/virtualbox/4.1.18/build/built-in.o
LD /var/lib/dkms/virtualbox/4.1.18/build/vboxdrv/built-in.o
CC [M] /var/lib/dkms/virtualbox/4.1.18/build/vboxdrv/linux/SUPDrv-linux.o
CC [M] /var/lib/dkms/virtualbox/4.1.18/build/vboxdrv/SUPDrv.o
CC [M] /var/lib/dkms/virtualbox/4.1.18/build/vboxdrv/SUPDrvSem.o
CC [M] /var/lib/dkms/virtualbox/4.1.18/build/vboxdrv/r0drv/alloc-r0drv.o
CC [M] /var/lib/dkms/virtualbox/4.1.18/build/vboxdrv/r0drv/initterm-r0drv.o
CC [M] /var/lib/dkms/virtualbox/4.1.18/build/vboxdrv/r0drv/memobj-r0drv.o
CC [M] /var/lib/dkms/virtualbox/4.1.18/build/vboxdrv/r0drv/mpnotification-r0drv.o
CC [M] /var/lib/dkms/virtualbox/4.1.18/build/vboxdrv/r0drv/powernotification-r0drv.o
CC [M] /var/lib/dkms/virtualbox/4.1.18/build/vboxdrv/r0drv/linux/assert-r0drv-linux.o
CC [M] /var/lib/dkms/virtualbox/4.1.18/build/vboxdrv/r0drv/linux/alloc-r0drv-linux.o
CC [M] /var/lib/dkms/virtualbox/4.1.18/build/vboxdrv/r0drv/linux/initterm-r0drv-linux.o
CC [M] /var/lib/dkms/virtualbox/4.1.18/build/vboxdrv/r0drv/linux/memobj-r0drv-linux.o
/var/lib/dkms/virtualbox/4.1.18/build/vboxdrv/r0drv/linux/memobj-r0drv-linux.c: In function 'rtR0MemObjNativeMapUser':
/var/lib/dkms/virtualbox/4.1.18/build/vboxdrv/r0drv/linux/memobj-r0drv-linux.c:1451:38: error: 'VM_RESERVED' undeclared (first use in this function)
/var/lib/dkms/virtualbox/4.1.18/build/vboxdrv/r0drv/linux/memobj-r0drv-linux.c:1451:38: note: each undeclared identifier is reported only once for each function it appears in
make[2]: *** [/var/lib/dkms/virtualbox/4.1.18/build/vboxdrv/r0drv/linux/memobj-r0drv-linux.o] Error 1
make[1]: *** [/var/lib/dkms/virtualbox/4.1.18/build/vboxdrv] Error 2
make: *** [_module_/var/lib/dkms/virtualbox/4.1.18/build] Fehler 2
make: Leaving directory `/usr/src/linux-headers-3.9.6'



Beteiligt euch am Aktionstag gegen die massenhafte Überwachung: https://thedaywefightback.org


Zum AUSTRAGEN schicken Sie eine Mail an debian-user-german-REQUEST@lists.debian.org
mit dem Subject "unsubscribe". Probleme? Mail an listmaster@lists.debian.org (engl)
Archive: http://lists.debian.org/trinity-cad...2046611848@3capp-gmx-bs38
 

Lesen sie die antworten

#1 Jens Schüßler
10/02/2014 - 19:20 | Warnen spam
* wrote:
Hallo in die Runde,

beim Installieren von Virtual Box-dkms erhalte ich folgende
Fehlermeldung, die, egal welches andere Paket ich installiere oder
aktualisiere, stàndig wiederholt. Es scheint sich um ein
zurückgehaltenes Paket zu handeln. Die Virtual Box wird auf dem GUI
incl. Icon als installiert angezeigt (Debian wheezy 32 bits). Was
kann ich tun, damit sich das nicht stàndig wiederholt und das Paket
endlich korrekt installiert wird?



Die Glaskugel sagt daß das Virtualbox-Modul nicht mehr mit einem 3.9
Kernel (der ist auch nicht aus wheezy) gebaut werden kann. Also entweder
Kernel-Downgrade oder virtualbox 4.2.16-dfsg-3~bpo70+1 von backports
installieren.

Und einen Realname anschaffen.


Zum AUSTRAGEN schicken Sie eine Mail an
mit dem Subject "unsubscribe". Probleme? Mail an (engl)
Archive: http://lists.debian.org/

Ähnliche fragen