Problem beim Kopieren von Dtaen aus Internettabelle

06/07/2010 - 16:07 von Jörch | Report spam
Hallo zusammen,
ich hab' hier ein Problem, für das ich noch auf keine Lösung gestossen
bin.

Ich kopiere mir Daten aus einer Tabelle von einer Webseite nach Excel,
weil ich die erst anch datum sortieren will, bevor ich sie
durchschaue. Latürnich bringt Excel die Datumswerte durcheinander, ein
Teil wird als dd-mm-yyyy und ein Teil als dd.mm.yyyy importiert.

Als mach' ich das mit dem multiplizieren. Eine 1 in eine Zelle
schreiben, kopieren, Datumsfelder markieren, Inhalte einfügen,
multiplizieren, Zahlenwerte nach Datumswert umwandeln, sortieren,
fertig.
Klappt auch prima.

Weil ich das aber öfters machn muss, hab' ich mir das mal als Makro
aufgezeichnet.

Sub Makro12()
Range("L2").Select
Selection.Copy
Range("I2:I11").Select
Selection.PasteSpecial Paste:=xlPasteAll, Operation:=xlMultiply, _
SkipBlanks:=False, Transpose:=False
Range("I2:I10").Select
Application.CutCopyMode = False
Range("I2:I11").Select
Selection.NumberFormat = "m/d/yyyy"
Range("I2").Select
Range("A1:L13").Sort Key1:=Range("I2"), Order1:=xlDescending,
Header:= _
xlGuess, OrderCustom:=1, MatchCase:=False,
Orientation:=xlTopToBottom, _
DataOption1:=xlSortNormal
End Sub

Wenn ich das Makro ausführe àndern sich die dd-mm-yyyy Werte nicht
mehr. an den "richtigen" Datumswerten wird alles so ausgeführt, wie
erwartet, da seh' ich, dass sie sich in eine Zahl verwandeln und dann
wieder auf Datum formatiert werden.

Habt Ihr eine Idee, wodran das liegen könnte?
Danke
Jörg
 

Lesen sie die antworten

#1 Jörch
06/07/2010 - 16:08 | Warnen spam
Hier noch meine Excel Version 2003 SP3.
Danke
Jörg

Ähnliche fragen