Problem beim Referenz setzen.

10/04/2010 - 08:54 von Peter Haus | Report spam
Hallo zusammen,

ich suche gerade nach einer Erklàrung, wieso es beim setzen einer
Referenz, die ich auswàhle über Verweise -> RMT Verweis hinzufügen ->
[TAB COM] -> Microsoft Outlook 11.0 Object Library
TypeLib Ver.9.2 c:\Progr...\msoutl.olb zu einem Fehler kommt.
Daran zu sehen, da in der Verweis Anzeige, zu dem Verweis, ein
Dreieck(Schild) mit Ausrufezeichen angezeigt wird.
Outlook 2003 funktioniert auf dem PC.
Des weiteren die Frage.
Ich kann beim setzen von Verweisen, auch im Tab NET einen Verweis
"Microsoft.Office.Interop.Outlook" auswàhlen.
Wieso geht der erste Verweis nicht und was ist der Unterschied, ob der
Verweis im, NET oder COM Tab verwendet wird?

Danke für eine Antwort
Peter
 

Lesen sie die antworten

#1 Armin Zingler
10/04/2010 - 10:02 | Warnen spam
Am 10.04.2010 08:54, schrieb Peter Haus:

Hallo zusammen,

ich suche gerade nach einer Erklàrung, wieso es beim setzen einer
Referenz, die ich auswàhle über Verweise -> RMT Verweis hinzufügen ->
[TAB COM] -> Microsoft Outlook 11.0 Object Library
TypeLib Ver.9.2 c:\Progr...\msoutl.olb zu einem Fehler kommt.



Kannst du für mich bitte entschlüsseln was ein "RMT Verweis" ist?
Ist das neu in 2010?

Daran zu sehen, da in der Verweis Anzeige, zu dem Verweis, ein
Dreieck(Schild) mit Ausrufezeichen angezeigt wird.



Geht manchmal weg, wenn man einfach darauf klickt.


Ansonsten in der Kommandozeile testen:

tlbimp.exe Pfad-zur-COM.dll /v

Fehlermeldungen? Wenn nicht aufschlussreich evtl zur weiteren
Eingrenzung Parameter /strictref anwenden (kann aufwendig werden).

Outlook 2003 funktioniert auf dem PC.
Des weiteren die Frage.
Ich kann beim setzen von Verweisen, auch im Tab NET einen Verweis
"Microsoft.Office.Interop.Outlook" auswàhlen.
Wieso geht der erste Verweis nicht und was ist der Unterschied, ob der
Verweis im, NET oder COM Tab verwendet wird?



Unter ".NET" findest du die installierten PIAs:
http://msdn.microsoft.com/en-us/lib...7sdch.aspx
http://msdn.microsoft.com/en-us/lib...06t57.aspx

Unter "COM" wird beim Setzen erst eine Interop-Assembly erzeugt:
http://msdn.microsoft.com/en-us/lib...y44e4.aspx

Armin

Ähnliche fragen