Problem: Exchange 2007 - OWA - Zertifikate

06/08/2008 - 14:55 von Schwanitz David | Report spam
Hallo zusammen,

des Thema ist bestimmt schon oft angesprochen worden aber ich komm einfach
nicht weiter.
Ich möchte Outlook Webaccess über einen ISA 2006 für unsere Mitarbeiter
ermöglichen hab aber ein Problem mit den Zertifikaten.

Ich habe eine Domàne bei 1&1 eingerichtet die auf unsere IP-Adresse des
ISA-Servers verweist. Über diese Adresse erreicht man
auch das OWA. Davor kommt die Meldung im IE7 das ein Problem mit dem
Sicherheitszertifikat der Webseite besteht. Wenn man sich
dann versucht anzumelden am OWA kommt die Fehlermeldung
"Die Seite kann nicht angezeigt werden. Fehlercode: 500 Interner
Serverfehler. Der Zielprinzipalname ist falsch."

Server:
Windows Server 2003 R2 - Exchange Server 2007 mit SP1
Windows Server 2003 R2 - Zertifizierungsstelle und ein paar andere
Verwaltungsdienste

Als nàchstes hab ich versucht das die Fehlermeldung über das
Sicherheitszertifikat vom IE7 intern verschwindet.

Meine Schritte waren folgende:

- Vom Exchange aus hab ich bei unserer internen Zertifizierungsstelle über
http://<servername>/certsrv ein Zertifikat für einen Webserver
angefordert und installiert.
- Über die Exchange-Powershell hab ich dann das Zertifikat mit dem Befehl
Enable-ExchangeCertificate das Zertifikat für SMTP,IIS, usw. aktiviert
- Als nàchstes hab ich über http://<servername>/certsrv das
Zertifizierungsstellenzertifikat gedownloaded und auf dem Exchange bei
Vertrauenswürdigen
Stammzertifikaten importiert das unser Exchange dem Zertifizierungsstelle
vertraut.
- Im IIS überprüft ob das Zertifikat erfolgreich eingetragen wurde

das ist hab ich bis jetzt gemacht. Doch die Seite mit dem Fehler
Sicherheitszertifikat das vor dem OWA kommt besteht immer noch.
Vielleicht hat ja jemand ne Idee was ich alles falsch mach.

Vielen Dank im voraus für eure Hilfe.
 

Lesen sie die antworten

#1 Jens Baier
06/08/2008 - 22:06 | Warnen spam
Hi,

Davor kommt die Meldung im IE7 das ein Problem mit dem
Sicherheitszertifikat der Webseite besteht.



kein Problem, da Du wahrscheinlich kein kommerzielle Zertifikat verwendest?!

Wenn man sich
dann versucht anzumelden am OWA kommt die Fehlermeldung
"Die Seite kann nicht angezeigt werden. Fehlercode: 500 Interner
Serverfehler. Der Zielprinzipalname ist falsch."



siehe Artikel am Ende.

- Vom Exchange aus hab ich bei unserer internen Zertifizierungsstelle über
http://<servername>/certsrv ein Zertifikat für einen Webserver
angefordert und installiert.



OK

- Über die Exchange-Powershell hab ich dann das Zertifikat mit dem Befehl
Enable-ExchangeCertificate das Zertifikat für SMTP,IIS, usw. aktiviert



OK

- Als nàchstes hab ich über http://<servername>/certsrv das
Zertifizierungsstellenzertifikat gedownloaded und auf dem Exchange bei
Vertrauenswürdigen
Stammzertifikaten importiert das unser Exchange dem Zertifizierungsstelle
vertraut.



sind Exchange Server und CA Server nicht in der gleichen Domaene? Wenn die
in der gleichen DOmaene sind, wird das Root CA Zertiifkat automatisch
verteilt.

- Im IIS überprüft ob das Zertifikat erfolgreich eingetragen wurde



OK und auch SSL gefordert?

Da fehlt jetzt noch einiges: Der ISA braucht auch das Root CA Zertiifkat
Fuer den ISA Listener brauchst Du auch ein Zertifikat, das auf den CN =
Common NAme = Name wie OWA aus dem Internet aufgerufen wird, ausgestellt
ist.
Auf der Registerkarte BIS muss der Name so eingetragen sein, wie das
Zertifikat am Exchange ausgestellt ist. Evtl. mit Patchen der HOSTS Datei
sicherstellen.
Mehr zu OWA:
http://www.msisafaq.de/Anleitungen/...WA_FBA.htm
(Gilt auch fuer ISA 2006)
Hier "the source":
http://technet.microsoft.com/en-us/...02619.aspx

Gruss Jens
www.nt-faq.de
www.blog.it-training-grote.de
www.it-training-grote.de

Ähnliche fragen