Problem mit abgelaufenem Zertifikat

08/12/2009 - 07:51 von Jo Michael | Report spam
Guten Morgen,

mein Zertifikat für den Exchange Server ist am Wochenende abgelaufen.
Es war ein "selbsterstelltes Zertifikat" mit einem internen
Zertifikatsserver.
Leider gibt es diesen Zertifikatsserver nicht mehr. Deshalb geht kein
"erneuern".

Kein Problem, dachte ich, und wollte ein neues Zertifikat erstellen.
Aber ich bekomme in der Shell stàndig die Meldung:
New-ExchangeCertificate : Entweder kann die Ausgabedatei
c:\SkriptewCert2009.req nicht überschrieben werden, weil für sie
Schreibschutz festgelegt wurde,oder Sie verfügen nicht über ausreichende
Berechtigungen zum Erstellen dieser Zertifikatanforderung.

Die Datei wird allerdings erstellt ohne Inhalt (0 Bytes).
Ich bin als Administrator angemelder und ich hab auch schon "Ausführen als"
mit Administrator probiert
(Das hat aber eher W2008 betroffen,ich hab W2003).

Meine Shell-Befehl lautete:
New-ExchangeCertificate -GenerateRequest -SubjectName "cÞ, o=Firmenname,
cn=mail.domain.de" -IncludeAcceptedDomains -IncludeAutodiscover -DomainName
mail.domain.de, srv-mail, srv-mail.dom.intern -privatekeyexportable
$true -Path c:\SkriptewCert2009.req

Ich hab einen Exchange 2007 SP2 mit W2003 R2 SP2 x64 im Einsatz.

Ich danke schonmal für jeden Hinweis,
gruss,
Jo
 

Lesen sie die antworten

#1 Walter Steinsdorfer [MVP]
08/12/2009 - 23:14 | Warnen spam
Hi,

mein Zertifikat für den Exchange Server ist am Wochenende abgelaufen.
Es war ein "selbsterstelltes Zertifikat" mit einem internen
Zertifikatsserver.
Leider gibt es diesen Zertifikatsserver nicht mehr. Deshalb geht kein
"erneuern".

Kein Problem, dachte ich, und wollte ein neues Zertifikat erstellen.
Aber ich bekomme in der Shell stàndig die Meldung:
New-ExchangeCertificate : Entweder kann die Ausgabedatei
c:\SkriptewCert2009.req nicht überschrieben werden, weil für sie
Schreibschutz festgelegt wurde,oder Sie verfügen nicht über ausreichende
Berechtigungen zum Erstellen dieser Zertifikatanforderung.

Die Datei wird allerdings erstellt ohne Inhalt (0 Bytes).
Ich bin als Administrator angemelder und ich hab auch schon "Ausführen
als" mit Administrator probiert
(Das hat aber eher W2008 betroffen,ich hab W2003).

Meine Shell-Befehl lautete:
New-ExchangeCertificate -GenerateRequest -SubjectName "cÞ, o=Firmenname,
cn=mail.domain.de" -IncludeAcceptedDomains -IncludeAutodiscover -DomainName
mail.domain.de, srv-mail, srv-mail.dom.intern -privatekeyexportable
$true -Path c:\SkriptewCert2009.req

Ich hab einen Exchange 2007 SP2 mit W2003 R2 SP2 x64 im Einsatz.

Ich danke schonmal für jeden Hinweis,



das hier hilft dir evtl. weiter:

http://msmvps.com/blogs/wstein/arch...euern.aspx

Viele Grüße aus München

Walter Steinsdorfer [MVP]
http://msmvps.com/blogs/wstein

Ähnliche fragen