problem mit AltGr slack13.1

25/02/2013 - 00:14 von Otto Mann | Report spam
Hallo

Ich habe ein merkwürdiges Problem mit Xorg

nach Starten des Xservers verhàlt sich die AltGr Taste im Xterm völlig normal,
nach làngerer Zeit führt sie jedoch einem Zeilenvorschub durch.
Die xorg.config ist automatisch eingerichtete, die Anpassung laut
Pat Voelkerding

If you need to use a non-US keyboard layout, then copy the file located
at
/usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi to
/etc/hal/fdi/policy
and edit it to suit your needs. Have a look at the contents of that
file
for an example and more information. If you prefer to do this the
"old" way
using /etc/X11/xorg.conf, then you can use "X -configure" or
"xorgsetup" to
generate an xorg.conf, then add the following lines to the
"ServerFlags"
section to disable input device hotplugging via HAL:
Option "AllowEmptyInput" "false"
Option "AutoAddDevices" "false"
Option "AutoEnableDevices" "false"

Was tun?

Gruß

Otto
 

Lesen sie die antworten

#1 Dirk Thierbach
25/02/2013 - 12:05 | Warnen spam
Otto Mann wrote:
Ich habe ein merkwürdiges Problem mit Xorg

nach Starten des Xservers verhàlt sich die AltGr Taste im Xterm völlig normal,
nach làngerer Zeit führt sie jedoch einem Zeilenvorschub durch.

Was tun?



Erstmal nachschauen, wo der Fehler liegt. Er muss nicht bei X liegen,
moeglicherweise ist auch die Tastatur defekt (Hardwarefehler).

Mit "xmodmap" siehst Du die Zuordnung der Tasten in X. Der X-Server
liest die events von der zugehoerigen /dev/input/eventX; welche
das ist, sieht man z.B. im Xorg.log. Mit "evtest" kann man diese
Geraetedatei auch direkt lesen.

Wenn auch mit evtest bei AltGr ein Zeilenverschob herauskommt, liegt
es garantiert nicht an X. Hardwarefehler ist dann sehr wahrscheinlich.

- Dirk

Ähnliche fragen