Forums Neueste Beiträge
 

Problem mit dem Einbinden eines Cryptofilesystems

17/12/2007 - 20:20 von gg01.20.rigger01 | Report spam
Hallo Experten,

ich habe ein Problem mit dem Einbinden eines Cryptofilesystems.
Es handelt sich dabei um einen verschlüsseltes Filsystem auf einem
50MB-Datenblock.

Damit der User das Dateisystem mounten kann, gibt es folgende Zeile in
der fstab:

/home/ich/crytpofile50mb /home/ich/mountpunkt ext3
noatime,user,noauto,acl,user_xattr,loop=/dev/
loop0,encryption=twofish,phash=sha512,itercountk0

Das Mounten funktionierte bisher reibungslos per "mount mountpunkt"
dann die Eingabe des Passwortes
und man konnte auf die Daten aus dem cryptofile zugreifen.

Nach einem Update von SuSE 10.2 auf 10.3 ist das jetzt ploetzlich
nicht mehr moeglich.
Kernel Version 2.6.22.

Die fstab enthaelt nach wie vor die besagte Zeile. Nach dem mount-
Befehlt wird auch das Passwort abgefragt aber dann passiert nichts
weiter. Das Filesystem wurde nicht am Mountpunkt eingebunden.

Modul loop_fish2 muss geladen sein. Ist es auch:
lsmod | grep fish
loop_fish2 15232 0
loop 21636 2 loop_fish2,cryptoloop

Mount-Befehlt als root auszufuehren, bringt auch kein besseres
Ergebnis.
Zudem keine Ausgabe in die /var/log/messages.

Das manuelle Mounten scheitert auch (als root):

pc3:/home/ich # mount -t ext3 -o encryption=twofish /home/ich/
crytpofile50mb /home/ich/mountpunkt
Switching to old S.u.S.E. loop_fish2 compatibility mode.
Warning: This mode is deprecated, support for it will be removed in
the future.
Passwort:
mount: wrong fs type, bad option, bad superblock on /dev/loop0,
missing codepage or helper program, or other error
Manchmal liefert das Syslog wertvolle Informationen - versuchen
Sie dmesg | tail oder so

Aber wenigstens sagt das Systemprotokoll was:
Dec 17 19:49:38 pc3 kernel: VFS: Can't find ext3 filesystem on dev
loop0.

Nun bin ich ein wenig ratlos. Ich bin mir sehr sicher, das ext3 das
Filesystem in dem Cryptofile ist.
Das Passwort kenne ich auch noch.
Dann habe ich das ganze mal auf einem Rechner probiert auf dem noch
SuSE 10.0 laeuft. Keine Besserung.
Das Fatale ist, dass wichtige Daten in dem Cryptofile sind. Die ich
jetzt auf z.B. truecrypt umziehen wuerde, ich muesste nur noch einmal
'drankommen.

Wie kann ich das analysieren / beheben?
Gruss,
Peter
 

Lesen sie die antworten

#1 Hauke Laging
17/12/2007 - 21:45 | Warnen spam
schrieb am Montag 17 Dezember 2007
20:20:

phash=sha512

Nach einem Update von SuSE 10.2 auf 10.3 ist das jetzt ploetzlich



Die Helden von SuSE haben das Verschlüsselungssystem auf LUKS
umgestellt, und irgendeine technische Änderung in diesem
Zusammenhang (ein anderes Verschlüsselungssystem) sorgt dafür,
dass "so obskure Parameter wie phash" nicht mehr funktionieren...


Wie kann ich das analysieren / beheben?



Gar nicht.


CU

Hauke
http://www.hauke-laging.de/ideen/
http://www.hauke-laging.de/software/
http://zeitstempel-signatur.hauke-laging.de/
Wie können 59.054.087 Leute nur so dumm sein?

Ähnliche fragen