Problem mit der kompatibilität zw Acc2010 u Acc2007

12/01/2011 - 09:07 von Andreas Gauer | Report spam
Hallo NG,

ich habe folgendes Problem, bei dem ich einfach nicht weiter komme
(Vielleicht sehe ich den Wald auch vor lauter Bàumen ncht ;-)

ich arbeite und erstelle DB's mit Access 2010 amerikanische Version,
die End-User benutzen dann diese DB's mit Access 2007 SP2 deutsche
Version. Beide unter Win7.

Jetzt habe ich ein Formular mit einem UFO welches bei mir (Access2010
amer.) ohne Problem Funktioniert und bei den User nicht. Das Problem
ist die Datenerkunft des UFO's.

Die SQL lautet wie folgt:

SELECT tblContainerAnlieferPlan.ID,
tblContainerAnlieferPlan.Schiff_ID,
tblContainerAnlieferPlan.Lieferanten_ID,
tblContainerAnlieferPlan.ABL_ID, tblContainerAnlieferPlan.Eta_Hafen,
tblContainerAnlieferPlan.Rechnung, tblContainerAnlieferPlan.Werk,
tblContainerAnlieferPlan.Container,
tblContainerAnlieferPlan.Teilenummer,
tblContainerAnlieferPlan.ASL_Teil, tblContainerAnlieferPlan.Lagerort,
tblContainerAnlieferPlan.Menge, tblContainerAnlieferPlan.Termin_Datum,
tblContainerAnlieferPlan.Termin_Uhrzeit,
tblContainerAnlieferPlan.CCC_Werk_Terminal,
tblContainerAnlieferPlan.Bemerkungen,
tblContainerAnlieferPlan.RDC_Datum_ein,
tblContainerAnlieferPlan.RDC_Uhrzeit_ein,
tblContainerAnlieferPlan.RDC_Nummer,
tblContainerAnlieferPlan.Ausgangstrailer,
tblContainerAnlieferPlan.Termin_xxx_Datum,
tblContainerAnlieferPlan.Termin_xxx_Uhrzeit,
tblContainerAnlieferPlan.xxx_Rollnr,
tblContainerAnlieferPlan.Gelöscht, tblContainerAnlieferPlan.Erledigt
FROM tblContainerAnlieferPlan
WHERE
(((tblContainerAnlieferPlan.Termin_xxx_Datum)>=DateAdd("ww",-6,Date())
Or (tblContainerAnlieferPlan.Termin_xxx_Datum) Is Null) AND
((tblContainerAnlieferPlan.Gelöscht)=False) AND
((tblContainerAnlieferPlan.Erledigt)=False));


Bei mir làuft sie ohne Problem, bei den User kommt die Fehlermeldung:
"Undefinierte Funktion 'Date' in Ausdruck"

Für Hilfe wàhre ich sehr Dankbar

Viele grüße
Andreas
 

Lesen sie die antworten

#1 Bernd Gilles
12/01/2011 - 11:22 | Warnen spam
Am 12.01.2011 09:07, schrieb Andreas Gauer:
ich habe folgendes Problem, bei dem ich einfach nicht weiter komme
(Vielleicht sehe ich den Wald auch vor lauter Bàumen ncht ;-)

ich arbeite und erstelle DB's mit Access 2010 amerikanische Version,
die End-User benutzen dann diese DB's mit Access 2007 SP2 deutsche
Version. Beide unter Win7.

Jetzt habe ich ein Formular mit einem UFO welches bei mir (Access2010
amer.) ohne Problem Funktioniert und bei den User nicht. Das Problem
ist die Datenerkunft des UFO's.

...

Bei mir làuft sie ohne Problem, bei den User kommt die Fehlermeldung:
"Undefinierte Funktion 'Date' in Ausdruck"



meist liegt das an einem kaputten Verweis.
http://www.donkarl.com?FAQ7.1

Gruß, Bernd

Access goes Subversion - http://oasis.dev2dev.de

Ähnliche fragen