Problem mit Doppelhop über LinkedServer

18/02/2009 - 08:26 von Volkmar Waluga | Report spam
Guten Morgen allerseits,

heute wende ich mal wieder an das Forum und hoffe auf Hilfe bei der Lösung
bei folgendem Problem.

Ich habe einen Client-PC (Vista), der mittels C#-Anwendung auf einem
SQL-Server (2000) eine Stored Procedure startet. Diese holt sich Daten über
eine LinkedServer-Verbindung von einem dritten PC (Test / WinXP), die dort
als dbase-Datei liegen.

Leider komme ich mit dem Rechte-Problem nicht weiter. Es erscheint die
Meldung: Der OLEDB-Provider meldete eine Fehler. … \\Test\Daten\ ist kein
zulàssiger Pfad.

Alle Maschinen befinden sich in einer Domàne und ich bin überall als Admin
angemeldet.

Wo überall muss ich denn Rechte vergeben? Irgendwie habe ich – so glaube ich
zumindest – schon alles versucht. Leider ohne Erfolg. Die SP auf dem Server
gestartet làuft natürlich korrekt.

Hat dazu jemand eine Idee?

Gruß Volkmar
 

Lesen sie die antworten

#1 Elmar Boye
18/02/2009 - 10:03 | Warnen spam
Hallo Volkmar,

Volkmar Waluga schrieb:
Ich habe einen Client-PC (Vista), der mittels C#-Anwendung auf einem
SQL-Server (2000) eine Stored Procedure startet. Diese holt sich Daten über
eine LinkedServer-Verbindung von einem dritten PC (Test / WinXP), die dort
als dbase-Datei liegen.

Leider komme ich mit dem Rechte-Problem nicht weiter. Es erscheint die
Meldung: Der OLEDB-Provider meldete eine Fehler. … \\Test\Daten\ ist kein
zulàssiger Pfad.

Alle Maschinen befinden sich in einer Domàne und ich bin überall als Admin
angemeldet.



Es spielt keine Rolle, was Du darfst.
Vielmehr, was das SQL Server Dienstkonto darf
Melde Dich mal über das Konto an, und schaue ob Du damit
auf die Netzwerkfreigabe zugreifen kannst.

Wenn nicht, richte ein Domànenkonto als SQL Server Dienstkonto ein
(falls nicht geschehen) und erlaube ihm den Zugriff auf die Freigabe.

Da der Zugriff auf Dbase Dateien üblicherweise über den Jet/Access
Treiber làuft, beachte auch:
<URL:sp_http://msdn.microsoft.com/de-de/lib...6.aspx>
"OLE DB-Anbieter für Jet"

Das heißt, ob das Verbindungskonto und die System.mdw richtig
eingerichtet sind.

Gruß Elmar

Ähnliche fragen