Problem mit gcc bei Installation vmware-tools

28/10/2008 - 09:58 von Curtis Newton | Report spam
Hallo,

ich habe ein Ubuntu neuester Version in einer virtuellen Maschine. Nun
versuche ich, in diesem Ubuntu die vmware-tools zu konfigurieren. Leider
erhalte ich eine Meldung, dass das installierte gcc nicht zum Kernel
passt:

Your kernel was built with "gcc" version "4.2.3", while you are trying
to use "/usr/bin/gcc" version "4.2.4". Your kernel was built with "gcc"
version "4.2.3", while you are trying to use "/usr/bin/gcc" version
"4.2.4".

$ ls -la /usr/bin/gcc*
lrwxrwxrwx 1 root root 7 2008-10-23 15:55 /usr/bin/gcc -> gcc-4.2
-rwxr-xr-x 1 root root 193372 2008-10-10 21:41 /usr/bin/gcc-4.2
-rwxr-xr-x 1 root root 2018 2007-06-05 02:59 /usr/bin/gccmakedep

Ich finde auch kein gcc-4.3, dass ich installiere kann. Was tun?

Bye
 

Lesen sie die antworten

#1 Sven Hartge
28/10/2008 - 14:24 | Warnen spam
Curtis Newton wrote:

ich habe ein Ubuntu neuester Version in einer virtuellen Maschine. Nun
versuche ich, in diesem Ubuntu die vmware-tools zu konfigurieren. Leider
erhalte ich eine Meldung, dass das installierte gcc nicht zum Kernel
passt:

Your kernel was built with "gcc" version "4.2.3", while you are trying
to use "/usr/bin/gcc" version "4.2.4". Your kernel was built with "gcc"
version "4.2.3", while you are trying to use "/usr/bin/gcc" version
"4.2.4".

$ ls -la /usr/bin/gcc*
lrwxrwxrwx 1 root root 7 2008-10-23 15:55 /usr/bin/gcc -> gcc-4.2
-rwxr-xr-x 1 root root 193372 2008-10-10 21:41 /usr/bin/gcc-4.2
-rwxr-xr-x 1 root root 2018 2007-06-05 02:59 /usr/bin/gccmakedep

Ich finde auch kein gcc-4.3, dass ich installiere kann. Was tun?



Wo steht denn da was von gcc-4.3? Da steht gcc-4.*2*.3.

Lösung: Die Meldung ignorieren. Solang du innerhalb 4.2.X bleibst, ist
die Wahrscheinlichkeit von Problemen sehr sehr gering.



Sig lost. Core dumped.

Ähnliche fragen