Problem mit gehe zu

05/03/2008 - 22:00 von Boas Steiner | Report spam
Hallo

Ich arbeite erst neu mit Acces(Office 2000)

Ich habe ein Formular mit einer eingebundenen Tabelle. Zum wechseln zwischen
den Datensàtzen benötige ich ein Button mit der Funktion "gehe zum nàchsten
Datensatz".

Ich habe im Entwurfsmodus ein Button gezeichnet und mit dem aufgerufenen
Assistent die obige Funktion ausgewàhlt.
Wenn ich nun in der Formularansicht auf den Button klicke, geht es zwar zum
nàchsten Datensatz, aber die eingebundene Tabelle wird nicht aktiviert.
Wie mach ich das, dass der sich Cursor nach dem Klicken im untersten
Datensatz der eingebundenen Tabelle befindet und dass ich gleich losschreiben
kann? Gibt es da eine Möglichkeit?

Ich bitte euch um eure Hilfe. Vielen Dank.

Gruss Boas
 

Lesen sie die antworten

#1 Thomas Möller
06/03/2008 - 07:42 | Warnen spam
Hallo Boas,

Boas Steiner schrieb:
Ich habe ein Formular mit einer eingebundenen Tabelle. Zum wechseln
zwischen den Datensàtzen benötige ich ein Button mit der Funktion
"gehe zum nàchsten Datensatz".

Ich habe im Entwurfsmodus ein Button gezeichnet und mit dem
aufgerufenen Assistent die obige Funktion ausgewàhlt.
Wenn ich nun in der Formularansicht auf den Button klicke, geht es
zwar zum nàchsten Datensatz, aber die eingebundene Tabelle wird nicht
aktiviert.
Wie mach ich das, dass der sich Cursor nach dem Klicken im untersten
Datensatz der eingebundenen Tabelle befindet und dass ich gleich
losschreiben kann? Gibt es da eine Möglichkeit?



was meinst Du in diesem Zusammenhang mit eingebundener Tabelle?

Wenn es sich um ein Unterformular handelt, dann musst Du zuerst das
Unterformular aktivieren bevor Du den Cursor in einen neuen Datensatz
setzen kannst:

Me!DeinUfoSteuerelement.SetFocus
DoCmd.GoToRecord , , acNewRec


HTH
Thomas

Homepage: www.Team-Moeller.de

Ähnliche fragen