Problem mit Kontaktformular

09/04/2008 - 21:44 von Alexander Szigetvary | Report spam
Hi NG!

Big problem!

Ich habe ein Kontaktformular als Sharepoint Webpart geschrieben, das
prinzipiell problemfrei funktioniert, allerdings nur wenn ich an der Site
angemeldet bin. Wenn ich anonym zugreife, dann bekomme ich einen Fehler

Ich generiere im Webpart einen neuen Listeneintrag in einer
Sharepoint-Liste. Dies löst dann einen Workflow aus, der das Mail versendet.
Anonymer Zugriff ist so eingestellt, dass man Elemente in der Liste anlegen
darf ( auch mit allen Rechten passiert der Fehler)

Hier mein Code:
EmailAdresseLesen(); // hier ermittle ich die Empfàngeremailadresse
SPListItemCollection items SPContext.Current.Site.RootWeb.Lists["Kontaktaufnahme"].Items;
SPListItem item = items.Add();
item["Vorname"] = Vorname.Text;
item["Nachname"] = Nachname.Text;
if (Firma.Text != "")
{
item["Firma"] = Firma.Text;
}
else
{
item["Firma"] = "-";
}
item["Email"] = Email.Text;
item["Text"] = Text.Text;
item["EmailEmpf"] = EmailEmpf;
item.Update(); // und hier krieg ich eine OutOfMemoryException

Interessanterweise wird das Listenelement, aber dennoch hinzugefügt,
allerdings der Workflow wird nicht ausgelöst.
Ohne Workflow passiert dasselbe. Fehler kommt, Element wird trotzdem
angelegt.

Irgendwelche Ideen? (Und schickt mich bitte nicht in die
Sharepoint-Newsgroup, die ist etwas zàh)

Alex
 

Lesen sie die antworten

#1 Gerold Mittelstädt
09/04/2008 - 23:15 | Warnen spam
Hallo Alexander!

Alexander Szigetvary schrieb:
Ich habe ein Kontaktformular als Sharepoint Webpart geschrieben, das
prinzipiell problemfrei funktioniert, allerdings nur wenn ich an der
Site angemeldet bin. Wenn ich anonym zugreife, dann bekomme ich einen
Fehler



Welchen denn?

Viele Grüße!

Ähnliche fragen