Problem mit KÜRZEN bzw. GANZZAHL

19/08/2009 - 14:55 von KarinLabisch | Report spam
Hallo NG, ich habe folgendes Problem und zweifle schon an mir selbst:
Eine Liste von errechneten Preisen in Spalte A soll bis € 0,35 ab-
bzw. ab € 0,36 auf ganze Euro aufgerundet werden (z.B. 112,35 € ergibt
112,00 € und 94,36 € ergibt 95,00 €) (bitte nicht fragen warum ;-)).
Ich habe nun versucht, das ganze mit folgender Formel zu lösen

=WENN(A3-(GANZZAHL(A3))<=0,35;ABRUNDEN(A3;0);AUFRUNDEN(A3;0))

und musste leider feststellen, dass manche Preise mit 35 Cent richtig
abgerundet und manche falsch aufgerundet wurden. Um diesen Fehler
einzugrenzen habe ich dann zwei Hilfsspalten angelegt, um die
Ermittlung der Cent-Betràge zu überprüfen, wahlweise mit £-(GANZZAHL
(A3)) oder £-(KÜRZEN(A3;0)) und habe über diese Hilfsspalten eine
bedingte Formatierung gelegt mit der Bedingung "Zellwert ist gleich
0,35". Erstaunlicherweise gibt es auch hier Zellen, die als 35 Cent
erkannt werden und andere wiederum nicht.

Warum ist das so und wer kann mir helfen? Bin für jeden Hinweis
dankbar.

Gruß Karin
 

Lesen sie die antworten

#1 {Boris}
19/08/2009 - 15:15 | Warnen spam
Hi Karin,

On 19 Aug., 14:55, KarinLabisch wrote:
Hallo NG, ich habe folgendes Problem und zweifle schon an mir selbst:
Eine Liste von errechneten Preisen in Spalte A soll bis € 0,35 ab-
bzw. ab € 0,36 auf ganze Euro aufgerundet werden (z.B. 112,35 € ergibt
112,00 € und 94,36 € ergibt 95,00 €) (bitte nicht fragen warum ;-)).
Ich habe nun versucht, das ganze mit folgender Formel zu lösen

=WENN(A3-(GANZZAHL(A3))<=0,35;ABRUNDEN(A3;0);AUFRUNDEN(A3;0))

und musste leider feststellen, dass manche Preise mit 35 Cent richtig
abgerundet und manche falsch aufgerundet wurden. Um diesen Fehler
einzugrenzen habe ich dann zwei Hilfsspalten angelegt, um die
Ermittlung der Cent-Betràge zu überprüfen, wahlweise mit £-(GANZZAHL
(A3)) oder £-(KÜRZEN(A3;0)) und habe über diese Hilfsspalten eine
bedingte Formatierung gelegt mit der Bedingung "Zellwert ist gleich
0,35". Erstaunlicherweise gibt es auch hier Zellen, die als 35 Cent
erkannt werden und andere wiederum nicht.

Warum ist das so und wer kann mir helfen? Bin für jeden Hinweis
dankbar.



Welche beispielhaften Zahlen werden denn nicht als 35 Cent erkannt?
Grundsàtzlich kann es auch schon mal zu excelinternen
Rundungsproblemen kommen (Fließkommaformat IEEE754 - mal googlen!).
Beispielsweise sollte man annehmen, dass
=(55-54,7)=0,3
im Ergebnis WAHR ergibt - Pustekuchen!
Fazit:
Es empfiehlt sich oft, Ergebnisse zu runden, bevor man mit ihnen
weiterrechnet.

Grüße Boris

Ähnliche fragen