Problem mit Master Pages

16/10/2007 - 20:39 von Jörg Haberfellner | Report spam
Hallo Leute!

Ich habe ein seltsames Phànomen in meiner Website. Habe eine Master Page
gemacht. Total aufwendig: On Top eine Grafik, darunter eine 3 spaltige
Tabelle: in der ersten Spalte ein Treeview Steuerelement mit der Navigation
(allerdings position: absolut positioniert, nicht irgendwie in der Tabelle),
zweite Spalte frei, dritte Spalte der Content Place Holder. Solange ich jetzt
weitere Seiten im Root Verzeichnis anlege und mit der Masterpage referenziere
làuft alles super.
Gerissen wie ich bin, habe ich aber einen Ordner angelegt und darin eine
ASPX Seite erzeugt die auf die Master Page referenziert. Jetzt passiert
folgendes: Das Menü ist zu sehen, den Content Place Holder gibt es, aber die
Tabelle mit den Hintergrundgrafiken ist verschwunden.
Was soll das? Kann mir da jemand behilflich sein?

Ich verwende Windows XP, .Net framework 2, und Visual Web Developer 2005
Express.

Danke schon einmal im voraus.

Jörg
 

Lesen sie die antworten

#1 Samaschke, Karsten
16/10/2007 - 20:54 | Warnen spam
N'Abend!

Gerissen wie ich bin, habe ich aber einen Ordner angelegt und darin eine
ASPX Seite erzeugt die auf die Master Page referenziert. Jetzt passiert
folgendes: Das Menü ist zu sehen, den Content Place Holder gibt es, aber die
Tabelle mit den Hintergrundgrafiken ist verschwunden.
Was soll das? Kann mir da jemand behilflich sein?



Blöde Frage: Die Hintergrundgrafiken sind nicht zufàllig relativ (also
in der Form "images/bla.gif") referenziert? Wenn ja, würde ich es mal
mit absoluter Referenzierung probieren - also "/images/bla.gif".

Mit freundlichen Gruessen / Best regards,

Karsten Samaschke
IT-Consulting, IT-Development, IT-Training
Homepage: http://www.ksamaschke.de
Weblog: http://www.karsan.de
Lesen! XML.NET-XML & WebServices mit .NET
http://www.amazon.de/exec/obidos/AS...spextra-21

Ähnliche fragen