Problem mit Motor-Endstufe

14/01/2009 - 14:12 von Thomas Kindler | Report spam
Hallo!

Ich hab' ein Problem mit einer 24V-Motor-Endstufe. Hinten hàngt ein
etwas größerer Scheibenwischermotor dran, Strom max. 10A.

Als FETs kommen IRFR3518 zum Einsatz, getrieben wird per IR2104S über
10R Gate-Widerstànde.

Leider gibt es ein Problem mit Shoot-Through: Immer, wenn die High-Side
einschaltet, werden die Gates der Low-Side kurzzeitig (wenige ns) über
die Schwellspannung gehoben.

Hier gibt's ein Oszillogramm:

http://t-kindler.de/~thomask/bridge1.jpg

Über einen 10mR-Shunt kann man für wenige ns Ströme im 100A-Bereich
messen.. das saut natürlich überall rein.

Der Aufbau sollte in Ordnung sein -- Multi-Layer-Platine, vernünftige
Leitungsführung, etc.. wir haben auch schon Prototypen mit anderen
Treiber-ICs und FETs gefràst (u.A. dem neuen TMC603-Treiber von
Trinamic, der explizit mit FETs mit hohem C_GD zurecht kommen soll) --
immer das gleiche Problem.

Was kann man dagegen tun? Größere Widerstànde am HS-Gate um dv/dt zu
verringern, und Shottky-Dioden parallel zu den FETs haben nur wenig
Abhilfe gebracht..

Oder ist das einfach normal? Dann müssten wir sehen, dass die restliche
Schaltung gegen die Störungen möglichst gut entkoppelt wird..

Thomas Kindler <mail+news@t-kindler.de>
 

Lesen sie die antworten

#1 MaWin
14/01/2009 - 14:24 | Warnen spam
"Thomas Kindler" <mail+ schrieb im Newsbeitrag
news:gkko4v$dfn$

Größere Widerstànde am HS-Gate um dv/dt zu verringern,



Hast du denn Widerstaende an LS-Gate ?
Weg damit.

LS muss niederohmig mit Masse verunden sein, waehrend
der Ausgang auf 24V steigt, sonst koppelt es von D ins G.
Manfred Winterhoff

Ähnliche fragen