Problem mit neuem Kernel 2.6.27 und Display

09/12/2008 - 18:46 von Andreas Kohlbach | Report spam
Ich habe den 2.6.27 (ja, ungerade ;-) kompiliert. Waehrend des Bootens
sieht das Display aus, als wuerde man Milch rein kippen. Alles wird
grau-weiss, es ist ein "Fade" Effekt, bis man die Buchstaben kaum noch
erkennen kann. Zumindest nicht genug, um zu sagen, was das Problem sein
koennte. Das passiert noch, bevor X hoch kommt. Wenn X dann hoch kommt,
wird es hellweiss.

Ich kann auf eine tty wechseln, aber immer noch nichts zu sehen, es wird
wieder grau-weiss.

dmesg endet mit:

[ 90.984163] pccard: PCMCIA card inserted into slot 0
[ 91.459051] pccard: CardBus card inserted into slot 1
[ 91.459221] pci 0000:06:00.0: found [10ec/8180] class 000200 header
type 00
[ 91.459254] PCI: 0000:06:00.0 reg 10 io port: [0, ff]
[ 91.459274] PCI: 0000:06:00.0 reg 14 32bit mmio: [0, 1ff]
[ 91.459354] pci 0000:06:00.0: supports D1
[ 91.459363] pci 0000:06:00.0: supports D2
[ 91.459375] pci 0000:06:00.0: PME# supported from D1 D2 D3hot D3cold
[ 91.459481] pci 0000:06:00.0: PME# disabled
[ 91.459598] pci 0000:06:00.0: BAR 1: got res [0x1c000000-0x1c0001ff]
bus [0x1c000000-0x1c0001ff] flags 0x20200
[ 91.459622] pci 0000:06:00.0: BAR 1: moved to bus
[0x1c000000-0x1c0001ff] flags 0x20200
[ 91.459640] pci 0000:06:00.0: BAR 0: got res [0x2c00-0x2cff] bus
[0x2c00-0x2cff] flags 0x20101
[ 91.459659] pci 0000:06:00.0: BAR 0: moved to bus [0x2c00-0x2cff]
flags 0x20101

Dann nichts mehr. Mir fielen ausserdem Meldungen wie

[ 0.028293] ACPI: setting ELCR to 0200 (from 0800)
[ 0.031434] khelper used greatest stack depth: 7620 bytes left
[ 0.031946] net_namespace: 760 bytes
[ 0.032841] Time: 18:05:57 Date: 12/09/08
[ 0.033142] NET: Registered protocol family 16
[ 0.034840] ACPI: bus type pci registered
[ 0.066922] PCI: PCI BIOS revision 2.10 entry at 0xf0484, last bus=1
[ 0.067009] PCI: Using configuration type 1 for base access
[ 0.068414] khelper used greatest stack depth: 7564 bytes left
[ 0.074131] ACPI: EC: Look up EC in DSDT
[ 0.111626] ACPI: Interpreter enabled
[ 0.111745] ACPI: (supports S0 S3 S4 S5)
[ 0.112011] ACPI: Using PIC for interrupt routing
[ 0.149036] khelper used greatest stack depth: 7548 bytes left
[ 0.160598] ACPI: PCI Root Bridge [C000] (0000:00)

auf, also etwas mit khelper. Ich weiss nicht, ob das mit dem Problem zu
tun hat. Laut Google hat das etwas mit CONFIG_DEBUG_STACK_USAGE zu tun.

Hat jemand eine Idee, was ich beim Kompilieren vergessen haben koennte?

OS ist Debian/Lenny.
Andreas (PGP Key available on public key servers)
BOFH excuse #205:
Quantum dynamics are affecting the transistors
 

Lesen sie die antworten

#1 Bernd Hohmann
09/12/2008 - 18:50 | Warnen spam
Andreas Kohlbach schrieb:
Ich habe den 2.6.27 (ja, ungerade ;-) kompiliert. Waehrend des Bootens
sieht das Display aus, als wuerde man Milch rein kippen.



Welche Grafikkarte, welche Treiber?

Bernd


Well, there's egg and bacon; egg sausage and bacon; egg and
; egg bacon and spam; egg bacon sausage
and ; spam bacon sausage and spam;spam
egg spam spam bacon and ; spam sausage

Ähnliche fragen