Problem mit Reportservice (SQL Server 2005)

08/10/2009 - 16:47 von Alex | Report spam
Hallo NG!

Mein ReportService liefert nur noch die Meldung, dass die Datei
ReportService2005.asmx nicht gefunden werden kann. Leider finde ich den
Grund dafür nicht. Ich vermute, dass irgendwas mit dem IIS nicht stimmt, da
die gesuchte Datei immer noch im SQL Server Programm-Ordner liegt. Hat
jemand eine Idee wo dran das liegen könnte und am Besten wie man es
vielleicht lösen kann?

Der Aufruf des Webservices über die Url
"http://<Servername>/reportserver/ReportService2005.asmx"
liefert als Antwort:







<?xml version="1.0" encoding="utf-8" ?>
- <soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/env...">
- <soap:Body>
- <soap:Fault>
<faultcode>Server</faultcode>
<faultstring>Die Datei /reportserver/ReportService2005.asmx ist nicht
vorhanden.</faultstring>
- <detail>
- <error xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema">
<displaytitle />
<displaytext />
<description>Die Datei /reportserver/ReportService2005.asmx ist nicht
vorhanden.</description>
<file>Not available</file>
<line>Not available</line>
<details>Die Datei /reportserver/ReportService2005.asmx ist nicht
vorhanden.</details>
<requesturl>http://<Servername>/reportserver/ReportService2005.asmx</requesturl>
<pathAndQuery>/reportserver/ReportService2005.asmx</pathAndQuery>
<source>SOAP</source>
<stacktrace />
</error>
</detail>
</soap:Fault>
</soap:Body>
</soap:Envelope>
<<

Der Aufruf von http://<servername>/reports/" liefert quasi die gleiche
Meldung:
"Die Datei /ReportServer/ReportService2005.asmx ist nicht vorhanden."

Danke für eure Hilfe

Gruß Alex
 

Lesen sie die antworten

#1 Klaus Sobel [MS]
08/10/2009 - 18:07 | Warnen spam
Hallo Alex,

Du kannst in der Metabase.xml die Einstellungen des Reportserver Virtual
Directory mit einer funktionierenden Installtion vergleichen.

Einfacher ist es jedoch mit dem RS Config Tool in dem Register 'Report
Server Virtual Directory' ein neues VD mit z.B. dem Namen 'Reportserver2'
anzulegen und dieses dann auszurufen

http://server/reportserver2

Wenn das funktioniert, kannst Du das VD Reportserver im IIS Manager löschen
und im Config Tool wieder neu erstellen.

mit freundlichen Grüssen

Klaus Sobel

EMEA BI Support



"Alex" wrote:

Hallo NG!

Mein ReportService liefert nur noch die Meldung, dass die Datei
ReportService2005.asmx nicht gefunden werden kann. Leider finde ich den
Grund dafür nicht. Ich vermute, dass irgendwas mit dem IIS nicht stimmt, da
die gesuchte Datei immer noch im SQL Server Programm-Ordner liegt. Hat
jemand eine Idee wo dran das liegen könnte und am Besten wie man es
vielleicht lösen kann?

Der Aufruf des Webservices über die Url
"http://<Servername>/reportserver/ReportService2005.asmx"
liefert als Antwort:
>>
<?xml version="1.0" encoding="utf-8" ?>
- <soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/env...">
- <soap:Body>
- <soap:Fault>
<faultcode>Server</faultcode>
<faultstring>Die Datei /reportserver/ReportService2005.asmx ist nicht
vorhanden.</faultstring>
- <detail>
- <error xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xsd="http://www.w3.org/2001/XMLSchema">
<displaytitle />
<displaytext />
<description>Die Datei /reportserver/ReportService2005.asmx ist nicht
vorhanden.</description>
<file>Not available</file>
<line>Not available</line>
<details>Die Datei /reportserver/ReportService2005.asmx ist nicht
vorhanden.</details>
<requesturl>http://<Servername>/reportserver/ReportService2005.asmx</requesturl>
<pathAndQuery>/reportserver/ReportService2005.asmx</pathAndQuery>
<source>SOAP</source>
<stacktrace />
</error>
</detail>
</soap:Fault>
</soap:Body>
</soap:Envelope>
<<

Der Aufruf von http://<servername>/reports/" liefert quasi die gleiche
Meldung:
"Die Datei /ReportServer/ReportService2005.asmx ist nicht vorhanden."

Danke für eure Hilfe

Gruß Alex



Ähnliche fragen