Problem mit Runtime Version 2007 - Laufzeitfehler

12/04/2010 - 20:20 von Johannes C. Laxander | Report spam
Hallo zusammen,

ich habe eine kleine Applikation unter A03 erstellt und davon mit A07 eine
Runtime-Version erzeugt. Wenn ich die A07-Runtime-Version starte wird in der
Statusleiste "Berechnung làuft..." angezeigt. Nach kurzer Zeit erhalte ich
dann die Fehlermeldung "Die Ausführung dieser Anwendung wurde wegen eines
Laufzeitfehlers angehalten. Die anwendung kann nicht weiter ausgeführt werden
und wird beendet."

Ich habe die Vermutung, dass es mit einer verküpften Grafikdatei
zusammenhàngt, weil die entsprechende Grafik im Formular noch nicht angezeigt
wird. Die Grafikdatei bestimme ich per VBA-Code:

Private Sub Form_Load()
Me!Logo.Picture = CurrentProject.Path & "\logo.jpg"
End Sub

Die Grafikdatei ist im Projektpfad vorhanden und unter A03 funktioniert das
Programm auch.

Weiss jemand Rat und kann mir sagen ob ich meiner Vermutung recht habe und
was das eigentliche Problem ist? Oder liegt die Ursache wo ganz anders? Wie
kann ich das überhaupt feststellen?

Gruß, Johannes.
 

Lesen sie die antworten

#1 Gunter Avenius
12/04/2010 - 20:43 | Warnen spam
Hallo Johannes,

Johannes C. Laxander schrieb folgendes:
ich habe eine kleine Applikation unter A03 erstellt und davon mit A07 eine
Runtime-Version erzeugt. Wenn ich die A07-Runtime-Version starte wird in der
Statusleiste "Berechnung làuft..." angezeigt. Nach kurzer Zeit erhalte ich
dann die Fehlermeldung "Die Ausführung dieser Anwendung wurde wegen eines
Laufzeitfehlers angehalten. Die anwendung kann nicht weiter ausgeführt werden
und wird beendet."

Ich habe die Vermutung, dass es mit einer verküpften Grafikdatei
zusammenhàngt, weil die entsprechende Grafik im Formular noch nicht angezeigt
wird. Die Grafikdatei bestimme ich per VBA-Code:

Private Sub Form_Load()
Me!Logo.Picture = CurrentProject.Path & "\logo.jpg"
End Sub

Die Grafikdatei ist im Projektpfad vorhanden und unter A03 funktioniert das
Programm auch.

Weiss jemand Rat und kann mir sagen ob ich meiner Vermutung recht habe und
was das eigentliche Problem ist? Oder liegt die Ursache wo ganz anders? Wie
kann ich das überhaupt feststellen?



In der RunTime sind keine JPG Grafikfilter enthalten.
Probiere: http://www.lebans.com/loadjpeggif.htm

Gruß
Gunter
__________________________________________________________
Access FAQ: http://www.donkarl.com

http://www.avenius.com - http://www.AccessRibbon.de
http://www.ribboncreator.de - http://www.ribboncreator2010.de

Ähnliche fragen