Problem mit URI::escape_char

07/09/2009 - 08:45 von Helmut Blass | Report spam
Hallo NG,
bekomme seit einiger Zeit beim Aufruf eines bestimmten Perl-Skripts
auf meinem Internet-Server ab und zu folgende Fehlermeldung:

Undefined subroutine &URI::Escape::escape_char called at /usr/local/
share/perl/5.8.8/URI.pm line 77.

Die genannte Routine wird _nicht_ von meinem Perl-Skript aufgerufen.
Mein Provider sagte mir, dass die neueste URI-Version installiert sei.
Möglicherweise tritt der Fehler erst seit der neuesten Version auf?!?
Vorher gab es jahrelang keine Probleme!
any ideas? thanx for your help,
Helmut
 

Lesen sie die antworten

#1 Frank Seitz
09/09/2009 - 09:25 | Warnen spam
Helmut Blass wrote:

bekomme seit einiger Zeit beim Aufruf eines bestimmten Perl-Skripts
auf meinem Internet-Server ab und zu folgende Fehlermeldung:

Undefined subroutine &URI::Escape::escape_char called at /usr/local/
share/perl/5.8.8/URI.pm line 77.

Die genannte Routine wird _nicht_ von meinem Perl-Skript aufgerufen.
Mein Provider sagte mir, dass die neueste URI-Version installiert sei.
Möglicherweise tritt der Fehler erst seit der neuesten Version auf?!?
Vorher gab es jahrelang keine Probleme!
any ideas? thanx for your help,



1) URI::Escape muss auf der Maschine existieren und
zum Zeitpunkt des Aufrufs geladen sein.
2) URI::Escape muss Subroutine escape_char() enthalten.

Das solltest du prüfen.
Wenn eine der beiden Bedingungen nicht erfüllt ist,
kommt es zu obigem Fehler.

Grüße
Frank
Dipl.-Inform. Frank Seitz; http://www.fseitz.de/
Anwendungen für Ihr Internet und Intranet
Tel: 04103/180301; Fax: -02; Industriestr. 31, 22880 Wedel

Ähnliche fragen