Problem mit VisualStudio.Shell.Interop.8.0

06/04/2010 - 14:00 von Sven Becker | Report spam
Hallo NG.

ich habe eine WindowsForm-Anwendung, die ich per ClickOnce unter
VisualStudio 2008 auf ein Serververzeichnis veröffentliche.

Plötzlich erhalten Benutzer dieses Programms, die kein VisualStudio
installiert haben, beim Installieren folgende Fehlermeldung:

"Die Anwendung kann weder installiert noch gestartet werden. Die Anwendung
erfordert, dass die Assembly Microsoft.VisualStudio.Shell.Interop.8.0 Version
8.0.0.0 zuerst im globalen Assemblycache (GAC) installisert wird."

Da die Anwendung hauptsàchlich von mir selbst benutzt wird, kann ich leider
keine Rückschlüsse auf Code-Änderungen nachvollziehen, die zu diesem Problem
geführt haben könnten.
Ich würde diese Assembly ja auch über die Verweise einbinden, bekomme sie
aber nicht angeboten. Eine Suche auf meiner lokalen Platte blieb auch
ergebnislos. Ebenso konnte ich in diversen Suchmaschinen nichts finden.

Bin über jeden Hiweis dankbar.

Gruß,
Sven
 

Lesen sie die antworten

#1 Sven Becker
06/04/2010 - 14:50 | Warnen spam
Habe jetzt doch selbst eine Lösung gefunden:
Musste in Projekteigenschaften->Veröffentlichen unter Anwendungsdateien bei
allen Komponenten den Veröffentlichungsstatus auf "Einschließen" setzen. Mit
der Einstellung "Einschließen (Auto)" hat's nicht mehr funktioniert.

Vielleicht kann mir da ja mal jemand einen Tipp geben.

Sven





"Sven Becker" wrote:

Hallo NG.

ich habe eine WindowsForm-Anwendung, die ich per ClickOnce unter
VisualStudio 2008 auf ein Serververzeichnis veröffentliche.

Plötzlich erhalten Benutzer dieses Programms, die kein VisualStudio
installiert haben, beim Installieren folgende Fehlermeldung:

"Die Anwendung kann weder installiert noch gestartet werden. Die Anwendung
erfordert, dass die Assembly Microsoft.VisualStudio.Shell.Interop.8.0 Version
8.0.0.0 zuerst im globalen Assemblycache (GAC) installisert wird."

Da die Anwendung hauptsàchlich von mir selbst benutzt wird, kann ich leider
keine Rückschlüsse auf Code-Änderungen nachvollziehen, die zu diesem Problem
geführt haben könnten.
Ich würde diese Assembly ja auch über die Verweise einbinden, bekomme sie
aber nicht angeboten. Eine Suche auf meiner lokalen Platte blieb auch
ergebnislos. Ebenso konnte ich in diversen Suchmaschinen nichts finden.

Bin über jeden Hiweis dankbar.

Gruß,
Sven

Ähnliche fragen