Problem: Windows-Installer streikt

11/01/2008 - 02:56 von Bernhard LERCHNER | Report spam
Hallo Leute!

Ich wusste nicht, wo ich meinen Beitrag sonst hinschreiben sollte, deshalb
ist er jetzt hier gelandet. Ich hoffe, es stört niemanden. :)

Also seit Kurzem verweigert mein Windows-Installer seinen Dienst und ich hab
keinen blassen Schimmer warum. Anfangs musste ich jedes Setup 2x starten,
weil er beim ersten Mal immer abgebrochen hat. Das war mir dann irgendwann
zu blöd, dann habe ich mir ein paar Tipps von der Microsoft-Seite geholt und
ausprobiert (neu registrieren, neuen downloaden/installieren, etc), hat aber
alles nichts geholfen. Nun öffnet sich - wenn ich auf eine msi-datei
doppelklicke - immer der "Öffnen-mit"-Dialog, also dachte ich mir, gibst ihm
einfach die msiexec.exe hàndisch - Fehlanzeige. Hab auch noch den ein oder
anderen zusàtzlichen Tipp ausprobiert, aber...

...der langen Rede, kurzer Sinn: Ich würde gerne diesen ***-Installer
komplett entfernen und nochmal schön sauber eine aktuelle Version auf mein
System aufspielen. Da ich schon Zeiten (offensichtlich sinnlos) herum
probiere, wàr mir mit einer Schritt-für-Schritt-Anleitung sehr geholfen!

Herzlichen Dank schon im Voraus für Eure Bemühungen!
Bernhard

PS:
WinXP Pro SP2 x86
 

Lesen sie die antworten

#1 Ottmar Freudenberger
11/01/2008 - 05:37 | Warnen spam
"Bernhard LERCHNER" schrieb:

Also seit Kurzem verweigert mein Windows-Installer seinen Dienst und ich hab
keinen blassen Schimmer warum.



Keine Microsoft-Dienste "zufàllig" deaktiviert oder eine Software
(de-)installiert?

Nun öffnet sich - wenn ich auf eine msi-datei
doppelklicke - immer der "Öffnen-mit"-Dialog, also dachte ich mir, gibst ihm
einfach die msiexec.exe hàndisch - Fehlanzeige.



Systemsteuerung | Ordneroptionen | Dateitypen
Hier "MSI" auswàhlen und sicherstellen, dass dort im Abschnitt "Öffnen
mit" der "Windows Installer" ausgewàhlt ist (ggf. "Wiederherstellen"
auswàhlen).

Dann schaust Du unter "Erweitert" nach. Dort "Install" markieren und
anschließend über "Bearbeiten" gehen.
Unter "Anwendung für diesen Vorgang" sollte das Folgende stehen:
"C:\WINDOWS\System32\msiexec.exe" /i "%1" %*
(und zwar *genau* so).
[X] DDE verwenden
DDE-Nachricht: [leer]
Anwendung: msiexec
DDE-Anwendung nicht aktiv: [leer]
Thema: System

Ist das bei Dir der Fall?

Bye,
Freudi
Macht euer Windows sicherer: http://windowsupdate.microsoft.com - jetzt!
http://www.microsoft.com/germany/sicherheit/
Infos zu aktuellen Patches für IE, OE und WinXP: http://patch-info.de
Letzte Aktualisierung: IE - 21.12.07 / OE - 09.10.07 / WinXP - 08.01.08

Ähnliche fragen