Forums Neueste Beiträge
 

Probleme bei der Installation der Software

18/11/2009 - 09:52 von Susann Markward | Report spam
Hallo,

ich nutze für die Erstellung der Setup-Routine u.a. noch eine alte
Version von InstallShield Express. Für neue Projekte nutze ich nur noch
Inno Setup.

Nun habe ich ein kleineres Problem bei der Verwendung der
Software-Setup-Routine, die mit InstallShield erstellt wurde.

Wenn ich die Setup.exe vor der Installation auf die HD kopiere und den
Installationsvorgang von der HD aus starte, gibt es keine Probleme.

Nun gibt es aber auch Kunden, die externe USB-HDs nutzen. Starte ich den
Installationsvorgang von dieser externen HD aus, verlàuft der
Installationsvorgang an sich ebenfalls normal. Starte ich die Software
mit angeschlossener HD einmal, scheint alles bestens. Starte ich jedoch
die Software ein zweites Mal, nun jedoch _ohne_ angeschlossene externe
HD, poppt ein Fenster auf, in welchem dem Anwender gemeldet wird, dass
nach einer Source gesucht wird, jedoch das msi-Paket der Setup-Routine
mit ebendieser Source nicht finden kann. Stecke ich nun die externe
Festplatte wieder an und starte die Software, funktioniert auch
zukünftig die Software ohne angeschlossene Festplatte.

Woran könnte das liegen?

Meine Setup-Routine besteht aus einer kleineren Setup.exe und einem
großen msi-Paket.

MfG
Susann
 

Lesen sie die antworten

#1 Wolfgang Bußmann
18/11/2009 - 17:11 | Warnen spam
Hallo Susann,

ein àhnliches Verhalten hatte ich mit einer anderen Software auch mal.

Bei mir lag es daran, dass mit der Installationsroutine eine Datei
installiert wurde, die ich spàter manuell gelöscht hatte. Irgendwie
scheint im "Hintergrund" von "irgendwem" geprüft worden zu sein, ob eine
Datei nicht mehr vorhanden ist und das Installationsprogramm wollte
sofort neu installieren. Nach dem wieder einspielen dieser Datei lief
alles wieder normal.

Allerdings trat dieses Verhalten bei mir nicht bei einer externen
Festplatte auf. Bei dir scheint ja wohl nach einem zweiten "Anlauf" das
Programm normal zu laufen.

ich nutze für die Erstellung der Setup-Routine u.a. noch eine alte
Version von InstallShield Express. Für neue Projekte nutze ich nur noch
Inno Setup.



Mich würden deine Erfahrungen mit InnoSetup interessieren, da ich evtl.
auch hierauf umstellen möchte?

Gruß Wolfgang

Ähnliche fragen