Probleme beim Ausdrucken von PDF

10/05/2015 - 16:20 von Jan Kappler | Report spam
This is an OpenPGP/MIME signed message (RFC 2440 and 3156)

Hallo Leute,

ich hab ein Problem mit CUPS.

System: Debian Squeeze LTS
Drucker: Konica Minolta magicolor 1650EN (über Ethernet angeschlossen)

Für den Drucker gibt es vom Hersteller zwei ppd-Files ("normal" und
"OpenOffice"), die ich eingerichtet habe. Ich verwende CUPS und das
Webinterface zum Administrieren.
Bisher funktionierte das Drucken auch weitgehend problemlos. Ich drucke
eher selten. Die release notes zu Debian 6 hatte ich bereits gedruckt,
sprich das hat schon funktioniert. Heute klappt das nun nicht mehr.

Fakten:
"normal": Text geht (z.B. normale txt-Datei in UTF-8), Bilder (GIF, JPG)
geht, PDF geht (offenbar) bis V1.3
"OpenOffice": OpenOffice-Dokumente (odf) geht

PDF, bei denen in den Eigenschaften z.B. PDF-1.2 oder PDF-1.3 steht,
kann ich mit Evince ausdrucken. Ab PDF-1.4 gibt der Drucker nur eine
Fehlerseite mit wechselnden Fehlern aus, mit denen ich nichts anfangen
kann. Grundsàtzlich steht da:

Error Status - magicolor 1650
Release 1.1, Firmware Level 22
Version 3011.045, Revision 13

Dann kommt dieses Schema:

Error name:
Offending operator:
Error info string:
VM Remaining:
For detailed information: Refer to the PostScript Language Reference
Manual, Third Edition.

Manchmal steht beim Name "undefinded", manchmal "stackunderflow", auch
die übrigen Werte variieren. Es folgen Tabellen mit "Operand Stack",
"Execution Stack" und "Dictionary Stack" sowie darunter "Program
Continuation:"
Der Inhalt stellt sich für mich eher kryptisch dar und wechselt bei den
Versuchen.

Auf einem zweiten Rechner mit Squeeze LTS habe ich den Drucker
nachtràglich eingerichtet, mit demselben Ergebnis - PDF wie die release
notes von Debian 6, 7 oder 8 lassen sich nicht ausdrucken.

Auf einer Test-Installation mit Debian 7 habe ich den Drucker ebenfalls
eingerichtet, allerdings zuerst keinen Drucker gefunden. Die Einrichtung
fand mehrere Eintràge für den magicolor, aber mittels IPP klappte es
nicht. Erst nachdem ich das Paket "Drucker-Server" nachinstalliert hatte
(es fehlte wohl noch was von CUPS), klappte der Druck zumindest direkt
aus dem Browser heraus (PDF-Version des Dokuments von der
Debian-Webseite, pdf.js vom Iceweasel). Der Druck produzierte allerdings
ein Dokument von über 70 MB Größe und dauerte gefühlt zwei Stunden.
Welche Pakete eingerichtet sind und welche vielleicht fehlen, will ich
zunàchst nicht nachprüfen.

Ich schàtze, die Rechner haben unter Squeeze ein Problem ab PDF-1.4,
obwohl das früher funktioniert hat. Wo könnte ich ansetzen, um das
Problem zu lösen?

P.S.: Ich will die Kisten natürlich bald auf Jessie aktualisieren, aber
über Wheezy natürlich. Weil meine Tests mit Gnome 3 eher katastrophal
ausgegangen sind und die Einrichtung von MATE etwas fummelig war und ich
zudem Probleme mit Grafik und Sound unter Wheezy habe, gibt es dafür die
Test-Installation. Ich würde vorher aber gern die Probleme unter Debian
6 lösen...



Mit freundlichem Gruß
Jan Kappler







Zum AUSTRAGEN schicken Sie eine Mail an debian-user-german-REQUEST@lists.debian.org
mit dem Subject "unsubscribe". Probleme? Mail an listmaster@lists.debian.org (engl)
Archive: https://lists.debian.org/554F6713.80301@jan-kappler.de
 

Lesen sie die antworten

#1 Martin Steigerwald
10/05/2015 - 20:00 | Warnen spam

Am Sonntag, 10. Mai 2015, 16:11:31 schrieb Jan Kappler:
Hallo Leute,

ich hab ein Problem mit CUPS.

System: Debian Squeeze LTS
Drucker: Konica Minolta magicolor 1650EN (à¼ber Ethernet angeschlossen)



Eine Idee noch:

Mal in der OpenPrinting Database, was fà¼r den Drucker empfohlen wird?

Und… unter Wheezy und spà¤ter gibt es printer-drivers-all. Das kippt zwar
erstmal eine Menge Zeug auf das System, aber dafà¼r kannst dann sicher sein,
dass Druckertreiber-technisch alles da ist, bis auf hplip fà¼r HP-Drucker,
denke ich.

Martin 'Helios' Steigerwald - http://www.Lichtvoll.de
GPG: 03B0 0D6C 0040 0710 4AFA B82F 991B EAAC A599 84C7




Zum AUSTRAGEN schicken Sie eine Mail an
mit dem Subject "unsubscribe". Probleme? Mail an (engl)
Archive: https://lists.debian.org/

Ähnliche fragen