Probleme beim crawlen von Öffentlichen Ordnern

18/06/2008 - 11:55 von Dirk Fust | Report spam
Hallo,

wir versuchen hier, öffentliche Ordner eines Exchange von MOSS aus zu
crawlen. Dazu wird eine HTTPS Verbindung genutzt. Dies schlàgt aber fehl, und
zwar mit folgenden Meldungen im Crawllog der entsprechenden Inhaltsquelle
(beide Meldungen haben den gleichen Timestamp):

[Rotes Fehlericon] rbs://exchange_server/public/folders
Exception from HRESULT: 0x80040E4D

[Grünes Erfolgsicon] https://exchange_server/public/folders
Crawled

Im Eventlog des Servers stehen keine Fehler, nur zwei Informationen, die den
Beginn (ID 4164) und das Ende (ID 4103) des Crawls anzeigen. Keine Fehler
oder Warnungen treten auf. Auch im (verbose) Tracelog des MOSS selbst haben
wir nichts gefunden, was uns weiterhilft.

Die Fehlermeldung 0x80040E4D scheint nach einer Internetsuche auf ein
SQL-Rechteproblem hinzudeuten. Das sollte aber eigentlich ausgeschlossen
sein, wir haben MOSS 2007 + SQL 2005 in einer virtuellen Maschine zum Testen
neu aufgesetzt, ein Account hat hier alle Rechte.

Generell versuchen wir derzeit erstmal, das Problem zu lösen,
Sicherheitserwàgungen spielen noch keine Rolle, da sich alles nur zu
Testzwecken im internen Netz abspielt.

Unsere derzeitige Idee ist, einen Exchange Frontendserver aufzusetzen, der
per HTTP (und nicht per HTTPS) angesprochen werden kann und der Zugriff auf
die öffentlichen Ordner des eigentlichen Exchange Servers bietet. Ist das
eine sinnvolle Idee, die funktionieren sollte? Zwar gibt es auch auf diesem
Weg einige Probleme und einige ermutigende Ergebnisse, aber hier sind wir
noch nicht allzu weit.

Ansonsten haben wir leider viele Vermutungen, was schief geht, aber keine
festen Hinweise auf eines dieser Probleme:

-Probleme mit SSL: Das SSL-Zertifikat des Exchange Servers könnte Probleme
bereiten (MOSS ist aber angewiesen, SSL Zertifikate auch bei Problemen
anzunehmen, der Schalter "SSL-Zertifikatsnamenswarnungen ignorieren" in der
Zentraladministration ist gesetzt)
-Rechteprobleme: Auch wenn wir dazu eigens eine VM aufgesetzt haben, auf der
der Crawlaccount auch alle sonstigen Rechte in MOSS, SQL Server, im AD und im
Betriebssystem hat, kann es natürlich sein, das es eine Ecke gibt, an die wir
nicht gedacht haben
-Fehlkonfiguration von MOSS oder Exchange

Wir wàren für Tips sehr dankbar!
Dirk
 

Lesen sie die antworten

#1 Jessica Heinz
01/07/2008 - 12:12 | Warnen spam
Hallo Dirk,

da bin ich doch gerade ueber dein Beitrag gestolpert.

1. Welchen Exchange Server benutzt ihr?

2. Schau dir mal folgendes an
http://technet.microsoft.com/en-us/...y/cc262907(TechNet.10).aspx


Gruesse
Jessica

Ähnliche fragen