Probleme jail + netzwerk

29/03/2008 - 08:06 von ngrundmann | Report spam
Hallo,

vielleicht kann mir jemand helfen. Problem ist der Zugriff auf das
Internet aus einer Jail in FreeBSD 7.0. Unter 6.2 hatte ich bisher
keine Probleme. Es ist so, (nach "enablen" der raw-sockets auf dem
host) dass das ping aus einer jail in das lokale Netz geht, aber nicht
nach ausserhalb. Auf dem host klappt unter 7.0 alles.

Folgende IP Adressen sind hier vorhanden
192.168.1.100 fuer den Router
192.168.1.7 host, der Rechner auf dem auf die jail laufen soll
192.168.1.20 jail


Die Grundeinstellung auf dem host ist folgendermassen:

/etc/resolv.conf
...
nameserver 192.168.1.100
...

/etc/rc.conf
...
defaultrouter="192.168.1.100"
ifconfig_em0="inet 192.168.1.7 netmask 255.255.255.0"
inetd_enable="YES"
inetd_flags="-wW -a 192.168.1.7"
...

(Die Adresse 192.168.1.7 wird nachher vor dem start der jail
"gesetzt")


Die Einstellung in der jail sind:

/etc/resolf.conf
wie auf dem host

/etc/rc.conf
...
network_interfaces=""
hostname="Porter"
sendmail_enable="NONE"
defaultrouter="192.168.1.100"
...


Startet man aus der jail einen ping nach 192.168.1.100, so geht das.
Ein ping nach 69.147.83.33 (www.freebsd.org) geht nicht, warum?

Parallel dazu sieht man auf dem host folgendes nach starten des
tcpdump -n:

07:29:00.042954 IP 192.168.1.20 > 69.147.83.33: ICMP echo request, id
1285, seq 0, length 64
07:29:00.240635 IP 69.147.83.33 > 192.168.1.20: ICMP echo reply, id
1285, seq 0, length 64

ifconfig liefert auf dem host:

em0: flagsˆ43<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu
1500
...
inet 192.168.1.7 netmask 0xffffff00 broadcast 192.168.1.255
inet 192.168.1.20 netmask 0xffffffff broadcast 192.168.1.20
...

Was mache ich falsch??

Gruesse, Norbert
 

Lesen sie die antworten

#1 Volker Stolz
31/03/2008 - 04:45 | Warnen spam
* :
vielleicht kann mir jemand helfen. Problem ist der Zugriff auf das
Internet aus einer Jail in FreeBSD 7.0. Unter 6.2 hatte ich bisher
keine Probleme. Es ist so, (nach "enablen" der raw-sockets auf dem
host) dass das ping aus einer jail in das lokale Netz geht, aber nicht
nach ausserhalb. Auf dem host klappt unter 7.0 alles.



Hallo Norbert,
fehlt evtl. ein gateway_enable="YES" 'auàŸerhalb' des Jails? (Nur geraten,
habe selber noch nie jails aufgesetzt).

Viele GràŒàŸe aus Macau,
Volker

Ähnliche fragen