Probleme mit Abfrage

22/03/2010 - 14:53 von Bernd Külpmann | Report spam
Hallo,

ich möchte eine Abfrage erstellen und bekomme Sie auch nach làngerem
Ausprobieren leider nicht hin.

Es handelt sich nur um 2 Tabellen mit jeweils 3 Feldern:
Tabelle1: Artikel, Monat, Umsatz
Tabelle2: Artikel, Monat, Bestand

In der Tabelle1 können Artikel enthalten sein, die in der Tabelle nicht drin
sind.
Der umgekehrte Fall ist allerdings ebenfalls möglich.

Wenn ich die beiden Tabellen direkt über die Felder Artikel und Monat
verknüpfe, kommen viel zu viele Datensàtze (die Anzahl multipliziert sich
offenbar).
Auf der anderen Seite fehlen aber auch Datensàtze. Das liegt wahrscheinlich
an der Gleichheitsverknüpfung.

Ich habe es auch schon mit einer oder mehreren Hilfstabellen versucht
(Artikeltabelle, Monatstabelle).
Aber leider funktioniert auch das nicht.

Wie kann ich die Abfrage nur hinbekommen??

Gruß
Bernd
 

Lesen sie die antworten

#1 Thomas Möller
22/03/2010 - 19:12 | Warnen spam
Hallo Bernd,

Am 22.03.2010 14:53, schrieb Bernd Külpmann:
ich möchte eine Abfrage erstellen und bekomme Sie auch nach làngerem
Ausprobieren leider nicht hin.

Es handelt sich nur um 2 Tabellen mit jeweils 3 Feldern:
Tabelle1: Artikel, Monat, Umsatz
Tabelle2: Artikel, Monat, Bestand

In der Tabelle1 können Artikel enthalten sein, die in der Tabelle nicht drin
sind.
Der umgekehrte Fall ist allerdings ebenfalls möglich.

Wenn ich die beiden Tabellen direkt über die Felder Artikel und Monat
verknüpfe, kommen viel zu viele Datensàtze (die Anzahl multipliziert sich
offenbar).



wenn es zu einem kartesischen Produkt kommt, dann scheint etwas mit der
Verknüpfung Deiner Tabellen nicht zu stimmen.
Post doch mal bitte den SQL-String Deiner Abfrage.


Auf der anderen Seite fehlen aber auch Datensàtze. Das liegt wahrscheinlich
an der Gleichheitsverknüpfung.



Dieses Problem gehen wir im zweiten Schritt an.


CU
Thomas

Homepage: www.Team-Moeller.de

Ähnliche fragen