Forums Neueste Beiträge
 

Probleme mit apt

30/08/2015 - 15:00 von Clemens Schüller | Report spam
Hallo!

Ich wollte gerade cmake installieren, aber:


apt will ein paar Pakete deinstallieren[1]

apt-get upgrade sagt[2] und dist-upgrade[3]


Wie kann ich dieses Problem lösen?






Footnotes:
[1] https://paste.debian.net/hidden/7d72721b/
[2] https://paste.debian.net/hidden/fe89a4d8/
[3] https://paste.debian.net/hidden/2918f76b/

Beste Grüße, Clemens Schüller
 

Lesen sie die antworten

#1 Michael Lange
30/08/2015 - 17:30 | Warnen spam
Hallo,

On Sun, 30 Aug 2015 14:54:14 +0200
Clemens Schüller <cs.mlists+ wrote:

Hallo!

Ich wollte gerade cmake installieren, aber:


apt will ein paar Pakete deinstallieren[1]

apt-get upgrade sagt[2] und dist-upgrade[3]


Wie kann ich dieses Problem lösen?




nur ein Schuss ins Blaue: ich habe vor einiger Zeit mal festgestell, dass
apt mitunter seltsame Dinge macht, wenn ein oder mehrere Mirrors aus der
sources.list nicht erreichbar sind. Mein Vorschlag für den Anfang deshalb
(falls du das noch nicht getan hast): lasse einmal apt-get update laufen
und schaue dir die Ausgabe an, ob es da mit einem oder mehreren Mirrors
Probleme gibt.

Konkret ist das mir bekannte Problem mit apt, dass im Falle, dass Pinning
genutzt wird (bei mir quasi unbewusst der Fall durch den Eintrag von
jessie-backports in der sources.list), ungewollte Pakete aus den
backports zum Installieren vorgemerkt wurden, sobald es beim durchführen
von apt-get update zu Verbindungsproblemen kam.

Gruss

Michael







Footnotes:
[1] https://paste.debian.net/hidden/7d72721b/
[2] https://paste.debian.net/hidden/fe89a4d8/
[3] https://paste.debian.net/hidden/2918f76b/

Beste Grüße, Clemens Schüller


Ähnliche fragen