Probleme mit dem AutoAcceptAgent

18/01/2008 - 18:36 von André | Report spam
Hallo @all,

auf einem W2k3Sp2 Server inkl Ex2003Sp2 ist der AutoAcceptAgent installiert.
In der Testumgebung sowie mit 3 realen Resourcenpostfàchern funktioniert
dieser problemlos, nur bei 2en, da gibt es Probleme.

Und zwar wie folgt:
Die Registrierung bzw. das Setzen der Berechtigungen bringt bei allen PF
keine Fehler.
Das Abfragen der Postfàcher mit listmailboxes.vbs listet alle PF richtig
auf.
Das Überprüfen der Ereignisregistrierung làuft bei allen ohne Probleme
durch, nur bei 2, da kommen folgende Fehler:




D:\Program Files\Exchsrvr\Agents\AutoAccept>cscript mailboxstatus.vbs
/m:konfere
nz.3@domain.com /debug
Microsoft (R) Windows Script Host Version 5.6
Copyright (C) Microsoft Corporation 1996-2001. All rights reserved.

<MailboxStatus>
<Summary>
<!--address filter = kon-raum.3@domain.com Length = 24-->
<CurrentTime>18.01.2008 18:21:25</CurrentTime>
<MailboxCount>1</MailboxCount>
</Summary>

<Mailbox EmailAddress="kon-raum.3@domain.com">
<!--Len(sMail) = 24-->
<!--searching <GC://domain.lan>;-->
<!--(&(objectClass=user)(mail=kon-raum.3@domain.com));-->
<!--<GC://domain.lan>;(&(objectClass=user)(mail=kon-raum.3@domain.com))
;msExchHomeServerName,mail,mailNickname;subtree-->
<!--1 records found-->
<!--Checking registration for kon-raum.3@domain.com-->
<!--url = http://ex01/exchange/kon-raum.3/-->
<!--http://ex01/exchange/kon-raum.3/HTTP/1.1 404 Resource Not Found-->
<!--namespace = xmlns:na='urn:schemas:httpmail:'-->
<!->
<!--DAVGet returned empty url for inbox-->
<Server>ex01</Server>
<RegistrationStatus>2</RegistrationStatus>
<RegistrationTime></RegistrationTime>
</Mailbox>
</MailboxStatus>


D:\Program Files\Exchsrvr\Agents\AutoAccept>cscript mailboxstatus.vbs
/m:konfere
nz.2@domain.com /debug
Microsoft (R) Windows Script Host Version 5.6
Copyright (C) Microsoft Corporation 1996-2001. All rights reserved.

<MailboxStatus>
<Summary>
<!--address filter = kon-raum.2@domain.com Length = 24-->
<CurrentTime>18.01.2008 18:21:30</CurrentTime>
<MailboxCount>1</MailboxCount>
</Summary>

<Mailbox EmailAddress="kon-raum.2@domain.com">
<!--Len(sMail) = 24-->
<!--searching <GC://domain.lan>;-->
<!--(&(objectClass=user)(mail=kon-raum.2@domain.com));-->
<!--<GC://domain.lan>;(&(objectClass=user)(mail=kon-raum.2@domain.com))
;msExchHomeServerName,mail,mailNickname;subtree-->
<!--1 records found-->
<!--Checking registration for kon-raum.2@domain.com-->
<!--url = http://ex01/exchange/kon-raum.2/-->
<!->
<!--namespace = xmlns:na='urn:schemas:httpmail:'-->
<!--DAVGet returned empty url for inbox-->
<Server>ex01</Server>
<RegistrationStatus>2</RegistrationStatus>
<RegistrationTime></RegistrationTime>
</Mailbox>
</MailboxStatus>



Hier die Ausgabe eines funktionierenden Postfaches:



D:\Program Files\Exchsrvr\Agents\AutoAccept>cscript mailboxstatus.vbs
/m:konfere
nz.1@domain.com /debug
Microsoft (R) Windows Script Host Version 5.6
Copyright (C) Microsoft Corporation 1996-2001. All rights reserved.

<MailboxStatus>
<Summary>
<!--address filter = kon-raum.1@domain.com Length = 24-->
<CurrentTime>18.01.2008 18:21:34</CurrentTime>
<MailboxCount>1</MailboxCount>
</Summary>

<Mailbox EmailAddress="kon-raum.1@domain.com">
<!--Len(sMail) = 24-->
<!--searching <GC://domain.lan>;-->
<!--(&(objectClass=user)(mail=kon-raum.1@domain.com));-->
<!--<GC://domain.lan>;(&(objectClass=user)(mail=kon-raum.1@domain.com))
;msExchHomeServerName,mail,mailNickname;subtree-->
<!--1 records found-->
<!--Checking registration for kon-raum.1@domain.com-->
<!--url = http://ex01/exchange/kon-raum.1/-->
<!--http://ex01/exchange/kon-raum.1/HTTP/1.1 200 OKhttp://ex01/exchan
ge/kon-raum.1/Posteingang-->
<!--namespace = xmlns:na='urn:schemas:httpmail:'-->
<!--http://ex01/exchange/kon-raum.1/Posteingang-->
<!--url = http://ex01/exchange/kon-raum.1/Posteingang/OnSaveForAutoAccep
tAgent-->
<!->
<!--namespace =
xmlns:na='http://schemas.microsoft.com/exchange/events/'-->
<Server>ex01</Server>
<RegistrationStatus>0</RegistrationStatus>
<RegistrationTime></RegistrationTime>
</Mailbox>
</MailboxStatus>


Die Berechtigungen auf dem Postfach schauen bei allen PF gleich aus. Per
Outlook wurden bestimmten Abteilungen, die für die Verwaltung dieser Ràume
zustàndig sein, Rechte der Stufe 2 erteilt, um hier Auskünfte über die
Belegung u.s.w. zu erteilen.
Dies betrittt das PF selbst, Eingang, Gesendete Objekte, Kalender, Gelöschte
Objekte
Standard und Anonym haben keine Berechtigungen.

Mir scheint es so, als ob die Postfàcher im Ex selber nicht korrekt angelegt
bzw. beschàdigt sind.

Kann mir jemand einen Tip geben, wie ich diesen Umstand beseitigen kann?

Vielen lieben Dank im voraus

André
 

Lesen sie die antworten

#1 André
18/01/2008 - 19:32 | Warnen spam
Nachtrag:

Habe bei beiden Fehlermailboxen die Postfàcher gelöscht und geleert.
Neue Postfàcher erstellt und diese regsitriert wieder keine Fehler.

Nun die Ausgabe von mailboxstatus.vbs:



D:\Program Files\Exchsrvr\Agents\AutoAccept>cscript MailboxStatus.vbs
/M:konfere
/debug
Microsoft (R) Windows Script Host Version 5.6
Copyright (C) Microsoft Corporation 1996-2001. All rights reserved.

<MailboxStatus>
<Summary>
<!--address filter = Length = 24-->
<CurrentTime>18.01.2008 19:23:25</CurrentTime>
<MailboxCount>1</MailboxCount>
</Summary>

<Mailbox EmailAddress="">
<!--Len(sMail) = 24-->
<!--searching <GC://domain.lan>;-->
<!--(&(objectClass=user)(mail=));-->
<!--<GC://domain.lan>;(&(objectClass=user)(mail=))
;msExchHomeServerName,mail,mailNickname;subtree-->
<!--1 records found-->
<!--Checking registration for
<!--url = http://ex01/exchange/kon-raum.2/-->
<!->
<!--namespace = xmlns:na='urn:schemas:httpmail:'-->
<!--DAVGet returned empty url for inbox-->
<Server>ex01</Server>
<RegistrationStatus>2</RegistrationStatus>
<RegistrationTime></RegistrationTime>
</Mailbox>
</MailboxStatus>


D:\Program Files\Exchsrvr\Agents\AutoAccept>cscript MailboxStatus.vbs
/M:konfere
/debug
Microsoft (R) Windows Script Host Version 5.6
Copyright (C) Microsoft Corporation 1996-2001. All rights reserved.

<MailboxStatus>
<Summary>
<!--address filter = Length = 24-->
<CurrentTime>18.01.2008 19:23:30</CurrentTime>
<MailboxCount>1</MailboxCount>
</Summary>

<Mailbox EmailAddress="">
<!--Len(sMail) = 24-->
<!--searching <GC://domain.lan>;-->
<!--(&(objectClass=user)(mail=));-->
<!--<GC://domain.lan>;(&(objectClass=user)(mail=))
;msExchHomeServerName,mail,mailNickname;subtree-->
<!--1 records found-->
<!--Checking registration for
<!--url = http://ex01/exchange/kon-raum.3/-->
<!->
<!--namespace = xmlns:na='urn:schemas:httpmail:'-->
<!--DAVGet returned empty url for inbox-->
<Server>ex01</Server>
<RegistrationStatus>2</RegistrationStatus>
<RegistrationTime></RegistrationTime>
</Mailbox>
</MailboxStatus>


Beim Einbinden in Outlook bzw. beim Buchen der beiden Resourcen taucht
folgender Fehler auf:

Der Vorgang konnte nicht ausgführt werden. Ein Objekt wurde nicht gefunden.
Für diese Besprechung können Ressourcen nicht direkt gebucht werden.


Diese Meldung verstehe ich auch, da im Vergleich zu den funktionierenden
Postfàchern einige Eintràge beim mailboxstatus.vbs Ausgabe fehlen.


Vielen Dank

André

Ähnliche fragen