Probleme mit ListView-Steuerelement

19/09/2008 - 15:51 von Rainer Burre | Report spam
Hallo,

ich habe eine User-Form mit einem Multipage Steuerelement.
Darauf befinden sich auf einigen Pages jeweils ein bis zwei ListViews.

Wenn ich das Formular ausführe und auf die entsprechenden Pages wechsle,
sind diese ListViews immer am oberen linken Rand ausgerichtet und erst wenn
ich
auf eine andere Page wechsle und danach wieder zurück gehe befindet sich das
ListView dort, wo ich es plaziert habe.
Diesen Effekt habe ich auch, wenn ich die ListItems àndere.

Ich habe auch schon in dem Page_Click-Ereignis die Left und Top Eigenschaft
immer neu gesetzt, aber hatte damit keinen Erfolg.
Die .Arrange-Eigenschaft ist auf lvwNone gesetzt.

Hat irgend jemand eine Idee?

Gruß
Rainer
 

Lesen sie die antworten

#1 Wolfram Jahn
19/09/2008 - 19:41 | Warnen spam
Rainer Burre schrieb:
Hallo,

ich habe eine User-Form mit einem Multipage Steuerelement.
Darauf befinden sich auf einigen Pages jeweils ein bis zwei ListViews.

Wenn ich das Formular ausführe und auf die entsprechenden Pages wechsle,
sind diese ListViews immer am oberen linken Rand ausgerichtet und erst wenn
ich
auf eine andere Page wechsle und danach wieder zurück gehe befindet sich das
ListView dort, wo ich es plaziert habe.
Diesen Effekt habe ich auch, wenn ich die ListItems àndere.

Ich habe auch schon in dem Page_Click-Ereignis die Left und Top Eigenschaft
immer neu gesetzt, aber hatte damit keinen Erfolg.
Die .Arrange-Eigenschaft ist auf lvwNone gesetzt.

Hat irgend jemand eine Idee?



Meine Idee ist, dass Du mal Deine Word Version, Dein Betriebssystem und
die Spracheinstellung nennst.

Bei mir (Word2000 auf XP SP3, beides deutsch) ist eine Userform mit
einem Standard Multiseiten Steuerelement mit einem Listview auf jeder
Seite und ohne jeden weiteren Code erstmal völlig unauffàllig, die
Positionen sind alle so wie im Design.

Also muss bei Dir irgendwas anders sein.


Wolfram

Ähnliche fragen