Probleme mit Munin .. oder dem Speicher?

08/09/2010 - 07:44 von Maxim Webster | Report spam
Moin,

seit dem Wechsel auf eine andere Hardware und von Debian Lenny 32Bit
auf Ubuntu 10.04 Server 64 Bit hab ich Probleme mit Munin, einem
Werkzeug zur Server-Überwachung.

Wàhrend der Ausführung durch Cron kommt es immer wieder zu
Laufzeitfehlern verschiedenster Art, z.B.:

*** glibc detected *** /usr/bin/perl: free(): invalid pointer:
0x0000000002a41850 ***
= Backtrace: ==/lib/libc.so.6(+0x775b6)[0x7f7dbc8015b6]
/lib/libc.so.6(cfree+0x73)[0x7f7dbc807e53]
/usr/lib/libperl.so.5.10(Perl_op_free+0x11a)[0x7f7dbd1eb82a]
/usr/lib/libperl.so.5.10(Perl_op_free+0xc4)[0x7f7dbd1eb7d4]

oder

Global symbol "$FILTERS_" requires explicit package name at /usr/share/
perl5/Log/Log4perl/Filter.pm line 56.
Missing right curly or square bracket at /usr/share/perl5/Log/Log4perl/
Filter.pm line 56, at end of line
syntax error at /usr/share/perl5/Log/Log4perl/Filter.pm line 56, at
EOF
Compilation failed in require at /usr/share/perl5/Log/Log4perl/
Config.pm line 12.

oder

Can't locate Errno.pm in @INC (@INC contains: /etc/perl /usr/local/lib/
perl/5.10.1 /usr/local/share/perl/5.10.1 /usr/lib/perl5 /usr/share/
perl5 /usr/lib/0erl/5.10 /usr/share/perl/5.10 /usr/local/lib/
site_perl .) at /usr/share/perl/5.10/English.pm line 187.
BEGIN failed--compilation aborted at /usr/share/perl/5.10/English.pm
line 187.
Compilation failed in require at /usr/share/munin/munin-update line 8.
BEGIN failed--compilation aborted at /usr/share/munin/munin-update
line 8.

oder (am hàufigsten) ein lapidares

Segmentation fault

Munin ist nicht der einizge Cron-Job, der 2-4 Sekunden làuft. Ich mach
mir ein bisschen Gedanken, ist Munin hier b0rken oder hab ich z.B. ein
RAM Problem.

Version von munin-node ist 1.4.4

Gruß,

Maxim
 

Lesen sie die antworten

#1 Markus Wichmann
08/09/2010 - 17:29 | Warnen spam
Maxim Webster schrieb:
Moin,

seit dem Wechsel auf eine andere Hardware und von Debian Lenny 32Bit
auf Ubuntu 10.04 Server 64 Bit hab ich Probleme mit Munin, einem
Werkzeug zur Server-Überwachung.

Wàhrend der Ausführung durch Cron kommt es immer wieder zu
Laufzeitfehlern verschiedenster Art, z.B.:

*** glibc detected *** /usr/bin/perl: free(): invalid pointer:
0x0000000002a41850 ***
= Backtrace: ==> /lib/libc.so.6(+0x775b6)[0x7f7dbc8015b6]
/lib/libc.so.6(cfree+0x73)[0x7f7dbc807e53]
/usr/lib/libperl.so.5.10(Perl_op_free+0x11a)[0x7f7dbd1eb82a]
/usr/lib/libperl.so.5.10(Perl_op_free+0xc4)[0x7f7dbd1eb7d4]




perl gibt einen falschen Pointer an free(). Mögliche Ursachen wàren
defekter RAM oder defekte libperl.

oder

Global symbol "$FILTERS_" requires explicit package name at /usr/share/
perl5/Log/Log4perl/Filter.pm line 56.
Missing right curly or square bracket at /usr/share/perl5/Log/Log4perl/
Filter.pm line 56, at end of line
syntax error at /usr/share/perl5/Log/Log4perl/Filter.pm line 56, at
EOF
Compilation failed in require at /usr/share/perl5/Log/Log4perl/
Config.pm line 12.




Defektes perl, defekter RAM oder defekte Filter.pm.

oder

Can't locate Errno.pm in @INC (@INC contains: /etc/perl /usr/local/lib/
perl/5.10.1 /usr/local/share/perl/5.10.1 /usr/lib/perl5 /usr/share/
perl5 /usr/lib/0erl/5.10 /usr/share/perl/5.10 /usr/local/lib/
site_perl .) at /usr/share/perl/5.10/English.pm line 187.
BEGIN failed--compilation aborted at /usr/share/perl/5.10/English.pm
line 187.
Compilation failed in require at /usr/share/munin/munin-update line 8.
BEGIN failed--compilation aborted at /usr/share/munin/munin-update
line 8.




Defektes perl, defekter RAM oder defekte Konfigurationsdatei.

oder (am hàufigsten) ein lapidares

Segmentation fault




Defekter RAM oder defektes Programm.

Munin ist nicht der einizge Cron-Job, der 2-4 Sekunden làuft. Ich mach
mir ein bisschen Gedanken, ist Munin hier b0rken oder hab ich z.B. ein
RAM Problem.




Also, entweder sind die genannten Dateien nicht mehr ganz ganz, oder
dein RAM ist kaputt. Oder, was natürlich auch geht, das Programm wird
schon defekt ausgeliefert. Können Download-Fehler ausgeschlossen werden?
(Integritàtsprüfung nach Download, etc.)

Version von munin-node ist 1.4.4

Gruß,

Maxim



HTH,
Markus

Ähnliche fragen