Probleme mit Netzwerk nach Klonen von Notebook

18/09/2010 - 00:57 von Uwe Bosse | Report spam
Hallo,
ich will mehrere Notebooks identisch einrichten mit ubuntu.
Dazu habe ich erstmal einen eingerichtet, dessen Partition
mit partimage gesichert und nun auf den andern nach
passender Partitionierung und Start von Live-CD
mit partimage die gesicherte Partition eingespielt
und den Bootloader installiert.

Das klappte alles wunderbar, nur dass die Netzwerk-Schnittstellen
eth0 und wlan0 einfach nicht vorhanden sind auf den Klonen.

Was könnte da schief laufen? wird etwa die Hardware-Adresse
auf die Platte geschrieben und auf dem Klon stimmt sie dann nicht?
Glaube ich eigentlich nicht.

Ich könnte auch damit leben, auf den Klonen das Netzwerk nachzuinstallieren.
Nur wie? Wie veranlasst man den Rechner zur Einrichtung von eth0?

Dank für Hilfe!
 

Lesen sie die antworten

#1 Andreas Kohlbach
18/09/2010 - 02:38 | Warnen spam
Uwe Bosse wrote on 17. September 2010:

ich will mehrere Notebooks identisch einrichten mit ubuntu.
Dazu habe ich erstmal einen eingerichtet, dessen Partition
mit partimage gesichert und nun auf den andern nach
passender Partitionierung und Start von Live-CD
mit partimage die gesicherte Partition eingespielt
und den Bootloader installiert.

Das klappte alles wunderbar, nur dass die Netzwerk-Schnittstellen
eth0 und wlan0 einfach nicht vorhanden sind auf den Klonen.



Die werden beim Laden des Treibers dynamisch erstellt. Verschiedene WLAN
Karten haben zum Beispiel verschiedene Namen. Mir ist schon wlanX, bei
einem anderen Rechner ethX (statt X halt eine Ziffer) unter gekommen.

Was könnte da schief laufen? wird etwa die Hardware-Adresse
auf die Platte geschrieben und auf dem Klon stimmt sie dann nicht?
Glaube ich eigentlich nicht.



Kann es sein, dass z.B. der WLAN Router eine bestimmte MAC Adresse
erwartet? Die beim anderen Computer natürlich anders ist.

Ich könnte auch damit leben, auf den Klonen das Netzwerk nachzuinstallieren.
Nur wie? Wie veranlasst man den Rechner zur Einrichtung von eth0?



Nur den Treiber laden. Wird normal automatisch "hoch genommen" (aktiviert).

ifconfig -a

zeigt dir an, was an Hardware, auch welche, die nicht "hoch genommen"
wurde, vorhanden ist.

ifconfig

sollte die anzeigen, die auch "oben" ist.
Andreas
Linux: The choice of a GNU generation.

Ähnliche fragen