Probleme mit openvpn

04/07/2010 - 20:00 von Uwe Forner | Report spam
Hallo,
ich habe auf meinem Debian Lenny Testserver openvpn installiert. Die
Konfiguration habe ich hier
http://www.online-tutorials.net/sec...9-209.html
entnommen.

Leider finde ich nirgendwo eine Einstellung für die IP des Servers in
der server.conf.

Wenn ich mit ifconfig nachschaue, ist kein tun-Device vorhanden. Laut
lsmod ist tun aber geladen.

Wer weiss, wie hier weiter vorzugehen ist. Der Debian soll als Server
über eine Fritzbox meinen Clienten einen VPN-Zugriff auf ihre
home-Directoriers ermöglichen.

MfG
Uwe
 

Lesen sie die antworten

#1 Harry Hirte
04/07/2010 - 21:47 | Warnen spam
On Sun, 04 Jul 2010 20:00:25 +0200, Uwe Forner wrote:

Hallo,
ich habe auf meinem Debian Lenny Testserver openvpn installiert. Die
Konfiguration habe ich hier
http://www.online-tutorials.net/sec...tutorials-


t-69-209.html
entnommen.

Leider finde ich nirgendwo eine Einstellung für die IP des Servers in
der server.conf.

Wenn ich mit ifconfig nachschaue, ist kein tun-Device vorhanden. Laut
lsmod ist tun aber geladen.

Wer weiss, wie hier weiter vorzugehen ist. Der Debian soll als Server
über eine Fritzbox meinen Clienten einen VPN-Zugriff auf ihre
home-Directoriers ermöglichen.




openvpn [ --mktun ] [ --rmtun ] [ --dev tunX | tapX ]
[ --dev-type device-type ] [ --dev-node node ] [ --lladdr
address ]
[ --user user ] [ --group group ]

also:

openvpn --mktun --dev tun0

In server.conf:
...
dev tun0
...
# Configure server mode and supply a VPN subnet
# for OpenVPN to draw client addresses from.
# The server will take 10.66.77:w.1 for itself,
# the rest will be made available to clients.
# Each client will be able to reach the server
# on 10.8.0.1. Comment this line out if you are
# ethernet bridging. See the man page for more info.
server 10.66.77.0 255.255.255.0


HH

Ähnliche fragen