Probleme mit push-pull converter

28/11/2010 - 01:31 von Frank Buss | Report spam
Ich habe mal den push-pull converter hier aufgebaut:

http://focus.ti.com/lit/an/slyt371/slyt371.pdf

Allerdings zum leichteren Testen werden die Steuersignale für Q1 und Q2 per
CPLD generiert, mit 100 kHz und 250 ns Totzeit. Die beiden FETs sind der
RTQ020N03. Als Transformator habe ich den 78253/55C eingesetzt:

http://www.murata-ps.com/data/magne..._78253.pdf

Mein Ziel ist, bei 3,3 V auf der Primàrseite, mindestens 4 V auf der
Sekundàrseite zu haben, bei 200 mA Last (damit ich das per LDO noch gut
nach 3,3 V regeln kann). Bei 200 mA Last fàllt die Spannung aber auf ca. 3
V ab, daher habe ich erstmal einen Brückengleichrichter drangebaut, mit dem
ich dann auch noch bei 250 mA Last eine Spannung von ca. 6 V habe.

Um wieder die einfachere Mittelpunktgleichrichtung verwenden zu können,
bràuchte ich wohl einen Transformator mit höherer Übersetzung als 1:1.3.
Kennt da einer einen passenden für meinen Anwendungsfall, den man bei
Digikey oder Farnell kaufen kann? Gut wàre auch, wenn der für 300 mA oder
mehr ausgelegt wàre, denn dann hàtte man noch etwas Reserve für die
angepeilten 200 mA Last auf der Sekundàrseite. Sollte aber nicht mehr als
ein paar Euro kosten.

Das zweite Problem ist eine Strombegrenzung. Wenn ich die Schaltung per
Labornetzteil mit Last einschalte, dann kommt es reproduzierbar vor, daß
scheinbar einer der FETs durchgeschaltet ist (was merkwürdig ist, da ich
einen 10 k Pulldown vorsichtshalber noch an den Gates angeschlossen habe),
und die Spannung zusammenbricht, weil mein Labornetzteil in die
Strombegrenzung geht (auf 1 A eingestellt). Der CPLD làuft dann nicht und
der Zustand bleibt dann so hàngen. Nur wenn ich es ohne Last einschalte,
dann scheint es zuverlàssig anzulaufen und dann kann ich die Last auch
dranhàngen. Wie kann man die Schaltung verbessern?

Spàter will ich auch einen Microcontroller einsetzen, um das PWM-Signal zu
generieren. Der kann natürlich auch mal abstürzen oder falsch programmiert
sein. Wie kann ich auf einfache Art und Weise einen Schutz einbauen? Ich
dachte an sowas, wenn der Strom über 200 mA steigt, daß dann die FETs
abgeschaltet werden und man es manuell (bzw. per Microcontroller) wieder
einschalten muß.

Frank Buss, http://www.frank-buss.de
piano and more: http://www.youtube.com/user/frankbuss
 

Lesen sie die antworten

#1 Dieter Wiedmann
28/11/2010 - 02:34 | Warnen spam
Frank Buss schrieb:

Allerdings zum leichteren Testen werden die Steuersignale für Q1 und Q2 per
CPLD generiert, mit 100 kHz und 250 ns Totzeit. Die beiden FETs sind der
RTQ020N03. Als Transformator habe ich den 78253/55C eingesetzt:

http://www.murata-ps.com/data/magne..._78253.pdf



Ziemlich viel Magnetisierungsstrom, schau dir den mal mit dem Oszi an.


Gruß Dieter

Ähnliche fragen