Probleme mit Sennheiser US-Headset

14/10/2009 - 02:07 von Aik Richter | Report spam
Hi

Ich hab seit einiger Zeit Porbleme mit dem Headset
Ist ein Sennheiser PC35 USB. Hat hier auf dem 9.04er Ubuntu 3 Monate
fehlerfrei funktioniert,bsp. um Videos mit dem VLC zu schauen.
Vor ner woche aber fiel mitten im Film der Ton aus, und in
/var/log/messages stand zu lesen:" usb 2-1: USB disconnect, address 2"

abstöpseln udn wieder anstecken brachte "sennheiser USb:Headset erkannt"
udn gleich wieder disconnect,solange das Video noch offen war. erst wenn
der VLC aus ist,blieben die Kopfhörer auch funktionsbereit. Fan dic
erstmal merkwürdig.
Ebenso merkwürdig aber ist,das unter WinXP (dualboot) die kopfhörer
nun auch ncith mehr funktionierten. Ein Bekannter meinte,möglicherweise
hàtte irgendwas den kleinen Computer im Lautstàrkeregler,der die
Funktion einer soundkarte übernimmt geàrgert,die Firmware überschrieben
oder beschàdigt. Dazu gegoogelt gabs ein Firmwareupdate,das unter Xp
eingespielt dem Headset ermöglicht,auch unter Vista zu laufen.
Gelesen-getan,Headset funzt unter Windows wieder. Funzt auc unter Linux
wieder,wenn man mit dem VLC mp3s hören will. Aber beim abspielen eines
Video (divx) flogen sie nach 2 minuten wieder raus.

Nun stellt sich die frage,wieso?
Sollte der Verdcht meines Bekanten zutreffen,frag ich mich,wer oder was
den die Firmware beschàdigt. und wieso,wo es doch 3 monate lang nich
tpassierte. NEin,es gab kein VLC update. Ja,unter XP kann ich das selbe
Video problemlos abspielen,im vlc,ohen das was passiert.

googelei unter dem Tag "ubuntu" brachte leider kein ergebnis,kommt wohl
ncith so oft vor.

Hat jemand ne Idee,wieso das passiert,udn besser noch,wie ich verhindern
kann,das es wieder passiert?
ICh kann das Video natürlich auch schauen wenn der ton aus den
Lautsprechern kommt,aber da eine Box verendet ist,und die andere schon
bessere zeiten sah,klingt es da nicht so dolle.

versionskrams: vlc sagt,er sei version 0.9.9a grishenko
Nein,es ist kein Kaffee übern Stecker vom Headset gelaufen :-)

Aik Richter
 

Lesen sie die antworten

#1 Dirk Thierbach
14/10/2009 - 21:44 | Warnen spam
Aik Richter wrote:
Ich hab seit einiger Zeit Porbleme mit dem Headset
Ist ein Sennheiser PC35 USB.



Wenn sonst keiner will:

Hat hier auf dem 9.04er Ubuntu 3 Monate
fehlerfrei funktioniert,bsp. um Videos mit dem VLC zu schauen.
Vor ner woche aber fiel mitten im Film der Ton aus, und in
/var/log/messages stand zu lesen:" usb 2-1: USB disconnect, address 2"

abstöpseln udn wieder anstecken brachte "sennheiser USb:Headset erkannt"
udn gleich wieder disconnect,solange das Video noch offen war. erst wenn
der VLC aus ist,blieben die Kopfhörer auch funktionsbereit. Fand ich
erstmal merkwürdig.

Ebenso merkwürdig aber ist,das unter WinXP (dualboot) die kopfhörer
nun auch nicht mehr funktionierten.



Vermutung: Irgendein kleiner Defekt in der Hardware. Kalte Loetstelle,
Elko kaputt, was auch immer. Tritt offenbar nur dann auf, wenn das
Ding dauernd benutzt wird, und viele Daten kriegt (also z.B. wg. Erwaermung).

Ein Bekannter meinte,möglicherweise hàtte irgendwas den kleinen
Computer im Lautstàrkeregler, der die Funktion einer soundkarte
übernimmt geàrgert,die Firmware überschrieben oder beschàdigt.



Firmware beschaedigt ist unwahrscheinlich.

Dazu gegoogelt gabs ein Firmwareupdate,das unter Xp eingespielt dem
Headset ermöglicht,auch unter Vista zu laufen.
Gelesen-getan,Headset funzt unter Windows wieder. Funzt auc unter
Linux wieder,wenn man mit dem VLC mp3s hören will. Aber beim
abspielen eines Video (divx) flogen sie nach 2 minuten wieder raus.



Ging's danach mit den mp3's wieder? Moeglicherweise ein Timing-Problem --
vielleicht kriegt er beim divx die Daten in kurzen Stoessen (bursts),
da sich der Rechner zwischendurch um's Bild kuemmert, waehrend es beim
mp3 regelmaessiger ist. Ist aber alles geraten.

Sollte der Verdacht meines Bekanten zutreffen,frag ich mich,wer oder was
den die Firmware beschàdigt. und wieso,wo es doch 3 monate lang nich
tpassierte.



Eben.

googelei unter dem Tag "ubuntu" brachte leider kein ergebnis,kommt wohl
ncith so oft vor.



Koenntest noch nach dem Modell und/oder USB-Id googeln in Verbindung
mit Stichworten wie "problem", "bug" oder so etwas.

Hat jemand ne Idee,wieso das passiert,udn besser noch,wie ich verhindern
kann,das es wieder passiert?



Wenn Du noch Garantie hast ("funktionierte 3 Monate" spricht ja dafuer),
wuerde ich versuchen, es umzutauschen (solange es noch geht). Wenn's wirklich
einer der obengenannten Hardware-Fehler ist, wird's naemlich nicht besser
werden. Wenn's was anderes ist (Firmware-Bug, was auch immer) schadet
ein Versuch nicht.

Bei solchen sporadisch auftretenden Fehlern ist das Problem immer,
nachzuweisen, dass der Fehler wirklich auftritt. Die schicken das
Geraet dann gerne ein, und dann kommt es mit einem "bei uns tritt der
Fehler nicht auf" zurueck. Da braucht man etwas Verhandlungsgeschick
(wichtig: immer freundlich bleiben, aber nachhaken), evtl. hilft eine
Demonstration vor Ort. Vorher mit dem Haendler ueber diesen Fall
reden ("es tritt immer nur ab und zu auf, was mache ich, wenn's
zufaellig bei denen nicht so ist?") schadet auch nicht.

- Dirk

Ähnliche fragen