Probleme mit SVERWEIS

29/07/2014 - 18:14 von Ralf Gläßer | Report spam
Halloli,

ich habe in einer Tabelle in einer Spalte A Namen und Spalte B eine
Kundenummer und in C und D zwei weitere Angaben.

Im Verlaufe der Zeit taucht aber ein Name ein zweites mal auf mit einer
anderen Kundennummer.

Bsp.:
A B
Meyer 100
Schulze 101
.
.
.
Meyer 112

Mit SVERWEIS soll nun in ein Formular die passenden Kundennummer zu dem
per Dropdown gewàhlten Namen und zwei weitere Angaben aus C und D
eingetragen werden.
Leider habe ich keine Ahnung wie ich hier irgendwie eine Unterscheidung
zwischen den beiden Meyers hinbekomme. Es wird immer nur die erste
Kundenummer genommen, egal welche Meyer ich per Dropdown wàhle.

=SVERWEIS(B14;A29:D127;2;0)

Excel 2003 und Excel 2010

Gib es da irgendwie eine Variante, ohne die Namen zu ergànzen oder zu
àndern?

Ich hatte noch vergessen, dass sich beide Meyers noch durch eine
Regionalkennung unterscheiden (Spalte E)
 

Lesen sie die antworten

#1 Claus Busch
29/07/2014 - 18:26 | Warnen spam
Hallo Ralf,

Am Tue, 29 Jul 2014 18:14:38 +0200 schrieb Ralf Glàßer:

Ich hatte noch vergessen, dass sich beide Meyers noch durch eine
Regionalkennung unterscheiden (Spalte E)



der Name in B14 dann in C14:
=INDEX(B$29:B$127;VERGLEICH($B14&"RK";$A$29:$A$127&$E$29:$E$127;0))
wobei "RK" die Regionalkennung ist. Diese kannst du auch in eine Zelle
schreiben und dann einen Zellbezug verwenden.
Auch diese Formel ist mit STRG+Shift+Enter abzuschließen.
Die anderen Angaben wie in der Antwort zuvor.


Mit freundlichen Grüßen
Claus
Vista Ultimate / Windows7
Office 2007 Ultimate / 2010 Professional

Ähnliche fragen