Probleme mit SVERWEIS

29/07/2014 - 17:46 von Ralf Gläßer | Report spam
Halloli,

ich habe in einer Tabelle in einer Spalte A Namen und Spalte B eine
Kundenummer und in C und D zwei weitere Angaben.

Im Verlaufe der Zeit taucht aber ein Name ein zweites mal auf mit einer
anderen Kundennummer.

Bsp.:
A B
Meyer 100
Schulze 101
.
.
.
Meyer 112

Mit SVERWEIS soll nun in ein Formular die passenden Kundennummer zu dem
per Dropdown gewàhlten Namen und zwei weitere Angaben aus C und D
eingetragen werden.
Leider habe ich keine Ahnung wie ich hier irgendwie eine Unterscheidung
zwischen den beiden Meyers hinbekomme. Es wird immer nur die erste
Kundenummer genommen, egal welche Meyer ich per Dropdown wàhle.

=SVERWEIS(B14;A29:D127;2;0)

Excel 2003 und Excel 2010

Gib es da irgendwie eine Variante, ohne die Namen zu ergànzen oder zu
àndern?
 

Lesen sie die antworten

#1 Claus Busch
29/07/2014 - 18:13 | Warnen spam
Hallo Ralf,

Am Tue, 29 Jul 2014 17:46:26 +0200 schrieb Ralf Glàßer:

Mit SVERWEIS soll nun in ein Formular die passenden Kundennummer zu dem
per Dropdown gewàhlten Namen und zwei weitere Angaben aus C und D
eingetragen werden.
Leider habe ich keine Ahnung wie ich hier irgendwie eine Unterscheidung
zwischen den beiden Meyers hinbekomme. Es wird immer nur die erste
Kundenummer genommen, egal welche Meyer ich per Dropdown wàhle.

=SVERWEIS(B14;A29:D127;2;0)



SVERWEIS findet immer nur den ersten Eintrag. Du musst dir die
Kundennummer schon selbst aussuchen.
Wenn du die Kundennummer hast, kannst du Namen und Kundennummer
verknüpfen und die restlichen Angaben mit Formel ergànzen.
Dein Name z.B. in B14 und die Kundennummer in C14, dann in D14:
=INDEX(C$29:C$127;VERGLEICH($B14&$C14;$A$29:$A$127&$B$29:$B$127;0))
Eingabe mit STRG+Shift+Enter abschließen und die Formel nach rechts
ziehen, um die zweite Angabe auch zu bekommen.


Mit freundlichen Grüßen
Claus
Vista Ultimate / Windows7
Office 2007 Ultimate / 2010 Professional

Ähnliche fragen