Probleme mit Touchpad

12/08/2009 - 23:25 von Bernd Eggink | Report spam
Hallo,

auf meinem Vaio-Notebook unter Crux 2.5 làuft X ohne xorg.conf. Schirm,
Tastatur, USB-Maus werden von HAL konfiguriert und funktionieren prima.
Was nicht geht, ist das Touchpad. Nur die beiden Tasten wirken, der
Mauszeiger làsst sich nicht bewegen. Es liegt nicht an der Hardware,
denn mit einer kleinen xorg.conf kriege ich auch das Touchpad zum
Laufen. Im Xorg-Protokoll sieht für mein Empfinden alles gut aus, z.B.
steht da:

(II) config/hal: Adding input device AlpsPS/2 ALPS GlidePoint
(**) AlpsPS/2 ALPS GlidePoint: always reports core events
(**) AlpsPS/2 ALPS GlidePoint: Device: "/dev/input/event4"
(II) AlpsPS/2 ALPS GlidePoint: Found 3 mouse buttons
(II) AlpsPS/2 ALPS GlidePoint: Found x and y relative axes
(II) AlpsPS/2 ALPS GlidePoint: Found x and y absolute axes
(II) AlpsPS/2 ALPS GlidePoint: Found absolute touchpad
(II) AlpsPS/2 ALPS GlidePoint: Configuring as touchpad
(**) AlpsPS/2 ALPS GlidePoint: YAxisMapping: buttons 4 and 5
(**) AlpsPS/2 ALPS GlidePoint: EmulateWheelButton: 4,
EmulateWheelInertia: 10, EmulateWheelTimeout: 200
(II) XINPUT: Adding extended input device "AlpsPS/2 ALPS GlidePoint"
(type: TOUCHPAD)
(**) AlpsPS/2 ALPS GlidePoint: (accel) keeping acceleration scheme 1
(**) AlpsPS/2 ALPS GlidePoint: (accel) filter chain progression: 2.00
(**) AlpsPS/2 ALPS GlidePoint: (accel) filter stage 0: 20.00 ms
(**) AlpsPS/2 ALPS GlidePoint: (accel) set acceleration profile 0

Mit "cat /dev/input/event4" sieht man, dass das Device korrekt Daten
liefert. Warum bewegt sich der Mauszeiger trotzdem nicht? Hat jemand
eine Erklàrung?

Gruß,
Bernd

Bernd Eggink
http://sudrala.de
 

Lesen sie die antworten

#1 Bernd Eggink
13/08/2009 - 21:21 | Warnen spam
Bernd Eggink schrieb:

auf meinem Vaio-Notebook unter Crux 2.5 làuft X ohne xorg.conf. Schirm,
Tastatur, USB-Maus werden von HAL konfiguriert und funktionieren prima.
Was nicht geht, ist das Touchpad. Nur die beiden Tasten wirken, der
Mauszeiger làsst sich nicht bewegen.



Hab's rausgefunden - in der Datei "10-x11-input.fdi" fehlten die
synaptics-spezifischen Eintràge, also

<match key="info.capabilities" contains="input.touchpad">
<merge key="input.x11_driver" type="string">synaptics</merge>
usw. ...
</match>

Bernd

Bernd Eggink
http://sudrala.de

Ähnliche fragen