Programmierbarer Frequenzteiler 74HC192

14/02/2011 - 20:17 von Stefan Heimers | Report spam
Hallo Allerseits,

Ich stehe vor einem kleinen Problem. Für eine PLL-Schaltung wollte ich
einen programmierbaren Frequenzteiler aufbauen.

Dazu habe ich mehrere 74HC192 kaskadiert (Uebertragsausgànge auf die
Zàhleingànge des nàchsten verbunden). Die Oszillatorfrequenz (ca. 6 bis
9MHz) wird auf den Abwàrtszàhleingang gegeben und jeweils auf 1kHz
heruntergeteilt.

Die Programmiereingànge hàngen an je einem BCD-Kodierschalter, mit
Pulldownwiderstand. Den letzten Abwàrts-Uebertrag habe ich auf alle
Load-Eingànge geführt. Somit sollte der Zàhler die eingestellte Frequenz
hinunterzàhlen und bei erreichen von 0 wieder die eingestellte Zahl laden.

Das funktioniert solange gut wie keiner der BCD-Schalter auf 0 steht.
Ich kann also alle Frequenzen einstellen die keine Ziffer '0' enthalten.
Sobald einer der Schalter auf 0 steht wird aber irgend eine falsche
Frequenz eingestellt.

Kennt jemand das Problem? Habe ich einen Denkfehler gemacht? Oder
spielen mir Spikes einen Streich? Das ganze ist auf einer
Lochrasterplatine aufgebaut, jeder Zàhler hat einen eigenen
Stützkondensator.


Gruss,
Stefan

http://www.heimers.ch/
 

Lesen sie die antworten

#1 Peter Kern
14/02/2011 - 20:53 | Warnen spam
Am 14.02.2011 20:17, schrieb Stefan Heimers:

Dazu habe ich mehrere 74HC192 kaskadiert (Uebertragsausgànge auf die
Zàhleingànge des nàchsten verbunden). Die Oszillatorfrequenz (ca. 6 bis
9MHz) wird auf den Abwàrtszàhleingang gegeben und jeweils auf 1kHz
heruntergeteilt.

Die Programmiereingànge hàngen an je einem BCD-Kodierschalter, mit
Pulldownwiderstand. Den letzten Abwàrts-Uebertrag habe ich auf alle
Load-Eingànge geführt. Somit sollte der Zàhler die eingestellte Frequenz
hinunterzàhlen und bei erreichen von 0 wieder die eingestellte Zahl laden.

Das funktioniert solange gut wie keiner der BCD-Schalter auf 0 steht.
Ich kann also alle Frequenzen einstellen die keine Ziffer '0' enthalten.
Sobald einer der Schalter auf 0 steht wird aber irgend eine falsche
Frequenz eingestellt.

Kennt jemand das Problem? Habe ich einen Denkfehler gemacht? Oder
spielen mir Spikes einen Streich? Das ganze ist auf einer
Lochrasterplatine aufgebaut, jeder Zàhler hat einen eigenen
Stützkondensator.



Schau mal hier:
http://www.zotteljedi.de/ttl-counter/index.html
Vielleicht gibbet was erhellendes.
Ansonsten Schaltung.jpg mal irgendwo ablegen.

Peter

Ähnliche fragen