ps (?) loest auf einmal exim UID nicht auf

04/01/2008 - 23:42 von Peter Mairhofer | Report spam
Hi,

Ist zwar keine recht dringende aber dennoch stoerts mich wenn was nicht so
laeuft wie es soll: Auf einmal zeigt ps als User nur die UID an statt dem
Benutzernamen (Debian-exim). Das passiert, seit ich zusaetzlich die NSS
auch per LDAP fuettere.
Aber bei allen andren Daemons funktioniert es!

# ps aux | grep exim
115 25734 0.0 0.4 13428 2172 ? Ss 15:30 0:00
/usr/sbin/exim4 -bd -q15m
root 8728 0.0 0.1 3100 744 pts/3 R+ 23:38 0:00 grep exim
# id Debian-exim
uid5(Debian-exim) gid5(Debian-exim) Gruppen5(Debian-exim),1007
(intranet),116(greylist)
# grep 115 /etc/passwd
Debian-exim:x:115:115::/var/spool/exim4:/bin/false
# grep Debian-exim /etc/shadow
Debian-exim:!:13562:0:365:14:::

An was koennte das liegen?

lg,
Peter
 

Lesen sie die antworten

#1 Henning Paul
04/01/2008 - 23:52 | Warnen spam
Peter Mairhofer schrieb:

Ist zwar keine recht dringende aber dennoch stoerts mich wenn was
nicht so laeuft wie es soll: Auf einmal zeigt ps als User nur die UID
an statt dem Benutzernamen (Debian-exim). Das passiert, seit ich
zusaetzlich die NSS auch per LDAP fuettere.
Aber bei allen andren Daemons funktioniert es!

# ps aux | grep exim
115 25734 0.0 0.4 13428 2172 ? Ss 15:30 0:00
/usr/sbin/exim4 -bd -q15m
root 8728 0.0 0.1 3100 744 pts/3 R+ 23:38 0:00 grep
exim
# id Debian-exim
uid5(Debian-exim) gid5(Debian-exim)
Gruppen5(Debian-exim),1007 (intranet),116(greylist)
# grep 115 /etc/passwd
Debian-exim:x:115:115::/var/spool/exim4:/bin/false
# grep Debian-exim /etc/shadow
Debian-exim:!:13562:0:365:14:::

An was koennte das liegen?



Daran, daß ps alle IDs lànger als 8 Zeichen nur numerisch darstellt.

Gruß
Henning
henning paul home: http://home.arcor.de/henning.paul
PM: , ICQ: 111044613

Ähnliche fragen