PyGTK mit Eclipse

25/11/2008 - 17:23 von Christof Kluß | Report spam
Hallo,

ich möchte PyGTK mit Eclipse 3.3 nutzen, dazu bin ich nach der Anleitung
auf http://faq.pygtk.org/index.py?req=s...23.043.htp
vorgegangen. Leider meldet Eclipse trotzdem noch "Unresolved import:
pygtk". Was mache ich falsch?

Meine Eclipse Einstellungen:

Unter "System PYTHONPATH" steht bei mir

/usr/lib/portage/pym
/usr/lib/python25.zip
/usr/lib/python2.5
/usr/lib/python2.5/plat-linux2
/usr/lib/python2.5/lib-tk
/usr/lib/python2.5/lib-dynload
/usr/lib/python2.5/site-packages
/usr/lib/python2.5/site-packages/Numeric
/usr/lib/python2.5/site-packages/gtk-2.0

und unter "Forced builtin libs" habe ich
"gtk", "gobject", "pango" und "atk" hinzugefügt.


Gruß,
Christof
 

Lesen sie die antworten

#1 Thomas Guettler
26/11/2008 - 16:47 | Warnen spam
Christof Kluß schrieb:
Hallo,

ich möchte PyGTK mit Eclipse 3.3 nutzen, dazu bin ich nach der Anleitung
auf http://faq.pygtk.org/index.py?req=s...23.043.htp
vorgegangen. Leider meldet Eclipse trotzdem noch "Unresolved import:
pygtk". Was mache ich falsch?




Funktioniert der import auf der Shell?

python


Python 2.5.1 (r251:54863, Aug 1 2008, 00:35:20)
[GCC 4.2.1 (SUSE Linux)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
import pygtk








Was ergibt:
pygtk.__file__






'/usr/lib64/python2.5/site-packages/pygtk.pyc'

Thomas


Thomas Guettler, http://www.thomas-guettler.de/
E-Mail: guettli (*) thomas-guettler + de

Ähnliche fragen