Python 2.5 django flup eunuchs fastcgi scgi

25/09/2007 - 09:54 von Thomas | Report spam
Hi ich hab folgendes Problem.

Ich hab Python 2.5 installiert danach Django. hat alles soweit
funktioniert.
Danach wollte ich FastCGI einrichten.http://www.djangoproject.com/
documentation/fastcgi/
Dafür brauch ich Flup. "http://trac.saddi.com/flup"
Dort steht wenn ich Python 2.4 und neuer hab brauch ich nicht Eunuchs
Wenn ich jetzt das Beispiel "manage.py runfcgi protocol=scgi" in
meinem Djangoprojektordner ausführe schreib er immer nur "can't import
flup.server.scgi_fork"

Wenn ich in der Python Shell "import flup.server.scgi_fork" eingebe
gibt er mir folgendes aus

"Traceback (most recent call last):
File "<pyshell#5>", line 1, in <module>
import flup.server.scgi_fork
File "C:\Python25\lib\site-packages\flup\server\scgi_fork.py", line
70, in <module>
from flup.server.preforkserver import PreforkServer
File "C:\Python25\lib\site-packages\flup\server\preforkserver.py",
line 53, in <module>
raise ImportError, 'Requires eunuchs module for Python < 2.4'
ImportError: Requires eunuchs module for Python < 2.4"

und den letzten beiden Zeilen das ich das eunuchs Modul brauche obwohl
ich ja Python 2.5 hab.
Ich hab eunuchs runtergeladen. http://www.inoi.fi/open/trac/eunuchs
Kann es über die Pythonkonsole importieren aber der Fehler ist immer
noch nicht weg.
Hat jemand von euch Erfahrung damit.

Danke im Vorraus.

Gruß Thomas Decker
 

Lesen sie die antworten

#1 Stefan Behnel
25/09/2007 - 10:01 | Warnen spam
Thomas schrieb:
[...]

Hi, ich habe deine Mail noch nicht gelesen, ich musste bei der Betreffzeile
schon lachen. Legst du es ernsthaft drauf an, in den Spam-Filtern anderer
Leute hàngen zu bleiben?

Stefan :)

Ähnliche fragen