python-Programm Gramps startet auf XP nicht

18/08/2014 - 12:36 von Gerd Schulz | Report spam
Hallo,

das Programm installiert sich, Ikons werden erstellt, Verzeichnisse sind
unter "Programme" und im Profil.
Beim Start des Programms, dem Doppelklick, passiert "etwas": die Sanduhr
sieht man eine kurze Zeit, und dann ist es aber "still" - also der
*Startprozess hàngt* irgendwo.
Im Process-Explorer (sysinternals) kann man sehen, das eine pythonw.exe
startet (grün). Dann verschwindet sie aber (rot & wech).
Auf anderem PC mit selbem XP habe ich Gramps problemlos installiert
bekommen.

Firewall ist ausgestellt (auf anderem PC làuft dieselbe firewall), AVG
deaktiviert.
Bei Installation mit aktiver firewall (ich habe ja mehrere Inst.
versucht), wird dreimal nach Berechtigung, Pyton anzuwenden gefragt, dem
ich natürlich (dauerhaft) zustimmte.

Aufgerufen wird das Programm so:
C:\Programme\GrampsAIO32\bin\pythonw.exe -EO ..\share\gramps\gramps.py

In einer Programm-Log steht:
2014-08-17 22:52:26.030: ERROR: gramps.py: line 107: Unhandled exception
Traceback (most recent call last):
File "..\share\gramps\gramps.py", line 479, in <module>
errors = run()
File "..\share\gramps\gramps.py", line 412, in run
from cli.argparser import ArgParser
File "C:\Programme\GrampsAIO32\share\gramps\cli\argparser.py", line
51, in <module>
import Utils
File "C:\Programme\GrampsAIO32\share\gramps\Utils.py", line 49, in
<module>
from gen.display.name import displayer as name_displayer
File "C:\Programme\GrampsAIO32\share\gramps\gen\displayame.py",
line 64, in <module>
from gen.lib import Name, NameOriginType
File "C:\Programme\GrampsAIO32\share\gramps\gen\lib\__init__.py",
line 27, in <module>
from gen.lib.date import Date, DateError, Span
File "C:\Programme\GrampsAIO32\share\gramps\gen\lib\date.py", line
594, in <module>
class Date(object):
File "C:\Programme\GrampsAIO32\share\gramps\gen\lib\date.py", line
668, in Date
_("calendar|Hebrew"),
File "C:\Programme\GrampsAIO32\share\gramps\gen\ggettext.py", line
89, in sgettext
return unicode(msgval)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 4:
ordinal not in range(128)


Hat jemand eine Idee, wo es hier haken könnte?


Gerd
 

Lesen sie die antworten

#1 Christoph Schneegans
18/08/2014 - 14:25 | Warnen spam
Gerd Schulz schrieb:

UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 4:
ordinal not in range(128)



Das Programm möchte das Byte 0xC3 mittels ASCII in ein Zeichen
decodieren, und das klappt korrekterweise nicht, denn ASCII kennt nur
die Bytes 0x00 bis 0x7F.

Frag in <news:de.comp.lang.python>, die können beim Debuggen helfen.

<http://schneegans.de/computer/safer/> · SAFER mit Windows

Ähnliche fragen