Forums Neueste Beiträge
 

Ralink rt2501 usb vollkommen instabile Verbindung

02/07/2010 - 23:56 von Marcel Müller | Report spam
Hallo,

ich kàmpfe jetzt hier schon eine Weile gegen einen USB-WLAN Stick mit
rt2501 Chip. Behandelt wird der wohl vom Treiber rt73usb.

Problem: die Datenrate laut iwconfig schwankt wie ein Ruderboot bei 8
Windstàrken. Und nach ein paar MB bricht eigentlich immer die Verbindung
ab. Um kurzzeitig wieder eine Verbindung zu bekommen, muss ich entweder
ifdown/ifup oder manchmal zusàtzlich modprobe rt73usb [-r] und
vielleicht jedes 10. mal sogar den Stick ziehen. In einem Fall gab es
sogar Kernel Panic mit irgendwas mit 80211 im Callstack.

Symptome gibt es reichlich, aber ich kann mir daraus keinen Reim daraus
machen.
- /var/log/syslog
No probe response from AP ... disconnecting
- iwlist scan liefert "No scan results" wenn er sich erst mal
verschluckt hat. Und das bis man wie oben neu startet.
- Stark schwankende Übertragungsrate (1MBit-54Mbit)
- txpower geht um 1dB über den per iwconfig setzbaren Maximalwert.
txpower 9 statt 8
- Der USB Stick wird glühheiß.

Kontext:
- Debian Lenny, Backport Kernel 2.6.32-bpo.5
- Link QualityP/70 Signal level=-60 dBm
- Entfernung zum AP ca. 5m flach an der Wand entlang.
- WPA mit wpasupplicant.

Ich habe mittlerweile an allen Parametern, die man per iwconfig setzen
kann, herumgespielt. Das bisherige Ende vom Lied,
- Nur mit "iwconfig wlan0 rate 11" làuft es.
- Mit allen anderen Raten, die ich bisher probiert habe nicht, darunter
auch kleinere, wie 6MBit und 9MBit.
- Wenn ich txpower manuell auf 3 dB setze, geht es (mit 11 MBit) genauso
gut und der Stick wird nicht so glühheiß.


Jetzt ist ja WLAN mit 54M schnarchlangsam. Weiß jemand, wie ich
wenigstens gut so 30 bis 40 MBit aus dem Stick heraushole, ohne dass an
einer Tour die Verbindung abraucht?


Marcel
 

Lesen sie die antworten

#1 Juergen Ilse
03/07/2010 - 02:03 | Warnen spam
Hallo,

Marcel Müller wrote:
ich kàmpfe jetzt hier schon eine Weile gegen einen USB-WLAN Stick mit
rt2501 Chip. Behandelt wird der wohl vom Treiber rt73usb.



Ich wuerde eher vermuten vom rt2500usb (der gehoert zu den rt2x00
Treibern, es sind also darueber hinaus noch ein paar weitere Kernel-
Module dafuer notwendig, ich vermute mal mindestens noch rt2x00usb,
rt2x00 lib,mac80211 und cfg80211, evt auch noch eeprom_93cx6).

Problem: die Datenrate laut iwconfig schwankt wie ein Ruderboot bei 8
Windstàrken. Und nach ein paar MB bricht eigentlich immer die Verbindung
ab. Um kurzzeitig wieder eine Verbindung zu bekommen, muss ich entweder
ifdown/ifup oder manchmal zusàtzlich modprobe rt73usb [-r] und
vielleicht jedes 10. mal sogar den Stick ziehen. In einem Fall gab es
sogar Kernel Panic mit irgendwas mit 80211 im Callstack.



Da kann ich dir ansonsten nichts zu sagen, da ich keinen solchen Stick
besitze (nur eine mini-PCI-Kart mit rt2500, bei der ich auch schon gele-
gentlich Eindrueche der Datenrate hatte, die sich dann durch ifdown/ifup
beseitigen liessen, aber Abstuerze hatte ich nie).

Tschuess,
Juergen Ilse ()
Ein Domainname (auch wenn er Teil einer Mailadresse ist) ist nur ein Name,
nicht mehr und nicht weniger ...

Ähnliche fragen